[bug#56612] guix install: Add '--manifest' option.
Commit Message
* guix/scripts/install.scm (show-help, %options): Add "--manifest".
* tests/guix-package-aliases.sh" Test "guix install -m".
---
guix/scripts/install.scm | 8 ++++++--
tests/guix-package-aliases.sh | 16 +++++++++++++---
2 files changed, 19 insertions(+), 5 deletions(-)
Hi!
I think it’s convenient and quite natural to be able to type:
guix install -m manifest.scm
Hence this patch. Objections? :-)
Thanks,
Ludo’.
Comments
Am Sonntag, dem 17.07.2022 um 12:20 +0200 schrieb Ludovic Courtès:
> * guix/scripts/install.scm (show-help, %options): Add "--manifest".
> * tests/guix-package-aliases.sh" Test "guix install -m".
> ---
> guix/scripts/install.scm | 8 ++++++--
> tests/guix-package-aliases.sh | 16 +++++++++++++---
> 2 files changed, 19 insertions(+), 5 deletions(-)
>
> Hi!
>
> I think it’s convenient and quite natural to be able to type:
>
> guix install -m manifest.scm
>
> Hence this patch. Objections? :-)
I think the semantics of `guix install -m' are somewhat unclear. It
can mean both "add all of manifest to what I already have installed"
and "use manifest exactly as the manifest". The latter is equivalent
to `guix package -m' (which has clearer semantics here) and also the
implementation chosen IIUC. Personally, I don't think I'd want
"install" to remove packages.
Cheers
Hi,
Liliana Marie Prikler <liliana.prikler@ist.tugraz.at> skribis:
> Am Sonntag, dem 17.07.2022 um 12:20 +0200 schrieb Ludovic Courtès:
>> * guix/scripts/install.scm (show-help, %options): Add "--manifest".
>> * tests/guix-package-aliases.sh" Test "guix install -m".
>> ---
>> guix/scripts/install.scm | 8 ++++++--
>> tests/guix-package-aliases.sh | 16 +++++++++++++---
>> 2 files changed, 19 insertions(+), 5 deletions(-)
>>
>> Hi!
>>
>> I think it’s convenient and quite natural to be able to type:
>>
>> guix install -m manifest.scm
>>
>> Hence this patch. Objections? :-)
> I think the semantics of `guix install -m' are somewhat unclear. It
> can mean both "add all of manifest to what I already have installed"
> and "use manifest exactly as the manifest". The latter is equivalent
> to `guix package -m' (which has clearer semantics here) and also the
> implementation chosen IIUC. Personally, I don't think I'd want
> "install" to remove packages.
Right. To me, ‘-m’ is always declarative: you get what the manifest
prescribes, nothing else; this is how it’s currently documented.
Do you think it could be interpreted as “add all of manifest to what I
already have installed”?
Ludo’.
Ludovic Courtès 写道:
> Do you think it could be interpreted as “add all of manifest to
> what I
> already have installed”?
It can; I did. I was going to raise the same objection as
Liliana. ‘guix package -m’ does not have this problem, ‘guix
install -m’ does.
Kind regards,
T G-R
Tobias Geerinckx-Rice <me@tobias.gr> skribis:
> Ludovic Courtès 写道:
>> Do you think it could be interpreted as “add all of manifest to what
>> I
>> already have installed”?
>
> It can; I did. I was going to raise the same objection as Liliana.
> ‘guix package -m’ does not have this problem, ‘guix install -m’ does.
OK, interesting. I guess we can drop the idea then.
Thanks for your feedback!
Ludo’.
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019, 2020, 2022 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,6 +33,9 @@ (define (show-help)
This is an alias for 'guix package -i'.\n"))
(display (G_ "
-p, --profile=PROFILE use PROFILE instead of the user's default profile"))
+ (display (G_ "
+ -m, --manifest=FILE create a new profile generation with the manifest
+ from FILE"))
;; '--bootstrap' not shown here.
(display (G_ "
-v, --verbosity=LEVEL use the given verbosity LEVEL"))
@@ -61,7 +64,8 @@ (define %options
;; Preserve some of the 'guix package' options.
(append (filter (lambda (option)
(any (cut member <> (option-names option))
- '("profile" "dry-run" "verbosity" "bootstrap")))
+ '("profile" "dry-run" "verbosity" "bootstrap"
+ "manifest")))
%package-options)
%transformation-options
@@ -1,5 +1,5 @@
# GNU Guix --- Functional package management for GNU
-# Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+# Copyright © 2019, 2020, 2022 Ludovic Courtès <ludo@gnu.org>
#
# This file is part of GNU Guix.
#
@@ -28,9 +28,10 @@ readlink_base ()
}
profile="t-profile-$$"
-rm -f "$profile"
+manifest="t-manifest-$$"
+rm -f "$profile" "$manifest"
-trap 'rm -f "$profile" "$profile-"[0-9]*' EXIT
+trap 'rm -f "$profile" "$profile-"[0-9]* "$manifest"' EXIT
guix install --bootstrap guile-bootstrap -p "$profile"
test -x "$profile/bin/guile"
@@ -55,6 +56,15 @@ guix remove --bootstrap guile-bootstrap -p "$profile"
! test -x "$profile/bin/guile"
test `guix package -p "$profile" -I | wc -l` -eq 0
+# Installing from a manifest.
+cat > "$manifest" <<EOF
+(specifications->manifest '("guile-bootstrap"))
+EOF
+guix install -p "$profile" -m "$manifest" --bootstrap
+test -x "$profile/bin/guile"
+guix remove --bootstrap guile-bootstrap -p "$profile"
+! test -x "$profile/bin/guile"
+
! guix remove -p "$profile" this-is-not-installed --bootstrap
! guix remove -i guile-bootstrap -p "$profile" --bootstrap