[bug#56478] gnu: Add cl-string-pokemonize.
Commit Message
* gnu/packages/lisp-xyz.scm (cl-string-pokemonize): New variable.
---
gnu/packages/lisp-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)
Comments
> I didn't mean to actually alternate the case in the synopsis. Is this
> intended or should I fix it?
I intended that but if you prefer for it to not be in pokemon case for
consistency with other Guix packages then feel free to change it and not use
the pokemon case in the synopsis.
all best,
jGaRt
Am Donnerstag, dem 21.07.2022 um 18:08 -0500 schrieb jgart:
> > I didn't mean to actually alternate the case in the synopsis. Is
> > this intended or should I fix it?
>
> I intended that but if you prefer for it to not be in pokemon case
> for consistency with other Guix packages then feel free to change it
> and not use the pokemon case in the synopsis.
PuShEd wItHoUt tHe pOkEmOn cAsE SyNoPsIs.
ChEeRs
On Sun, 10 Jul 2022 03:41:07 -0500 jgart <jgart@dismail.de> wrote:
ThAnKs!
@@ -22647,6 +22647,41 @@ (define-public cl-sketch
(define-public ecl-sketch
(sbcl-package->ecl-package sbcl-sketch))
+(define-public sbcl-string-pokemonize
+ (let ((commit "2dc01643defb497e4d1eb833def71dfc1e8d5da6")
+ (revision "0"))
+ (package
+ (name "sbcl-string-pokemonize")
+ (version (git-version "20210503" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/phoe/string-pokemonize")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zk5klc94pxv7mhx6qrp93rk4ypwd6wfijap7gf9l0wpphg90r9x"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:asd-files '("string-pokemonize.asd")
+ #:asd-systems '("string-pokemonize")))
+ (synopsis "Function to alternate uppercase and lowercase characters")
+ (description
+"Provides a function, @code{string-pokemonize} that alternates uppercase
+and lowercase characters for a given string. The entire code base is
+also entirely stylized in alternating uppercase and lowercase characters
+exemplifying Common Lisp's case insensitivity.")
+ (home-page "https://github.com/phoe/string-pokemonize")
+ (license license:expat))))
+
+(define-public cl-string-pokemonize
+ (sbcl-package->cl-source-package sbcl-string-pokemonize))
+
+(define-public ecl-string-pokemonize
+ (sbcl-package->ecl-package sbcl-string-pokemonize))
+
(define-public sbcl-binary-types
(let ((commit "9ec42042a50403961c08179a892ae3de725b1d7a"))
(package