@@ -495,6 +495,34 @@ It has been modified to remove all non-free binary blobs.")
#:patches %linux-libre-5.0-patches
#:configuration-file kernel-config))
+(define vhba-module
+ (package
+ (name "vhba-module")
+ (version "20170610")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://downloads.sourceforge.net/cdemu/vhba-module-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1v6r0bgx0a65vlh36b1l2965xybngbpga6rp54k4z74xk0zwjw3r"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; TODO: No tests?
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://cdemu.sourceforge.io/")
+ (synopsis "Kernel module that emulates SCSI devices")
+ (description "VHBA module provides a Virtual (SCSI) HBA, which is the link
+between the CDemu userspace daemon and linux kernel.")
+ (license license:gpl2+)))
+
+(define-public vhba-module-linux-libre
+ (make-linux-module linux-libre vhba-module))
+
(define %linux-libre-4.19-version "4.19.32")
(define %linux-libre-4.19-hash "19bryl8nmnnnrfh91pc8q9yiayh5ca2nb6b32qyx6riahc5dy0i9")