[bug#56557] k3b: Fix build
Commit Message
Hi reviewers,
k3b doesn't build anymore on current master due to a mix-up of CMake
variables. This patch fixes that.
It's probably a temporary issue because latest versions of k3b have
updated CMakeLists, but updating to a newer k3b also requires
updating all KDE Frameworks to version 5.88. So I hope we can
include the present fix for now.
It's been a while, hope this patch satisfies the requirements :-)
Sincerely,
Thomas
Comments
Hi Thomas,
Long time no see, welcome back! :-)
Thomas Danckaert <post@thomasdanckaert.be> skribis:
>>From 7adc6413918b633c9879d08a8fce531d67416f85 Mon Sep 17 00:00:00 2001
> From: Thomas Danckaert <thomas.danckaert@gmail.com>
> Date: Thu, 14 Jul 2022 14:21:17 +0200
> Subject: [PATCH 1/2] gnu: k3b: Fix build.
>
> * gnu/packages/kde-multimedia.scm (k3b)[phases]: Add phase fix-cmake-taglib in
> order to use correct Taglib include and library variables.
[...]
>>From 30b789b945a02e075d151a082bf30bf9fad3d006 Mon Sep 17 00:00:00 2001
> From: Thomas Danckaert <thomas.danckaert@gmail.com>
> Date: Thu, 14 Jul 2022 14:44:23 +0200
> Subject: [PATCH 2/2] gnu: k3b: Add inputs bash-minimal and cdrtools.
>
> * gnu/packages/kde-multimedia.scm (k3b)[inputs]: Add
> bash-minimal (wrap-program is used), add cdrtools.
Applied both, thanks!
Ludo’.
From 7adc6413918b633c9879d08a8fce531d67416f85 Mon Sep 17 00:00:00 2001
From: Thomas Danckaert <thomas.danckaert@gmail.com>
Date: Thu, 14 Jul 2022 14:21:17 +0200
Subject: [PATCH 1/2] gnu: k3b: Fix build.
* gnu/packages/kde-multimedia.scm (k3b)[phases]: Add phase fix-cmake-taglib in
order to use correct Taglib include and library variables.
---
gnu/packages/kde-multimedia.scm | 10 ++++++++++
1 file changed, 10 insertions(+)
@@ -373,6 +373,16 @@ (define-public k3b
(("\"(dvdcss)\"" _ library)
(string-append "\"" libdvdcss "/lib/" library "\""))))
#t))
+ (add-before 'configure 'fix-cmake-taglib
+ (lambda _
+ ;; Use the CMake variables provided by FindTaglib from
+ ;; extra-cmake-modules, instead of bundled FindTaglib.cmake:
+ (substitute*
+ '("plugins/decoder/mp3/CMakeLists.txt"
+ "plugins/decoder/flac/CMakeLists.txt"
+ "plugins/project/audiometainforenamer/CMakeLists.txt")
+ (("TAGLIB_INCLUDES") "Taglib_INCLUDE_DIRS")
+ (("TAGLIB_LIBRARIES") "Taglib_LIBRARIES"))))
(add-after 'qt-wrap 'wrap-path
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Set paths to backend programs.
--
2.36.1