[bug#56386,3/3] gnu: Add mecab-unidic.
Commit Message
* gnu/packages/language.scm (mecab-unidic): New variable.
---
gnu/packages/language.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
Comments
Hi,
Julien Lepiller <julien@lepiller.eu> skribis:
> + (synopsis "Dictionary data for MeCab")
> + (description "UniDic for morphological analysis is a dictionary for
> +analysis with the morphological analyser MeCab, where the short units exported
> +from the database are used as entries (heading terms).")
> + (license (list license:gpl2+ license:lgpl2.1 license:bsd-3))))
Maybe add a comment stating whether this is triple-licensed (at the
user’s choice) or if that means that there are files under each of
these.
Otherwise the whole series LGTM!
Ludo’.
@@ -27,6 +27,7 @@ (define-module (gnu packages language)
#:use-module (gnu packages autotools)
#:use-module (gnu packages audio)
#:use-module (gnu packages base)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages docbook)
#:use-module (gnu packages emacs)
#:use-module (gnu packages freedesktop)
@@ -57,6 +58,7 @@ (define-module (gnu packages language)
#:use-module (gnu packages xorg)
#:use-module (guix packages)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
@@ -997,3 +999,27 @@ (define-public mecab-ipadic
(description "This package contains dictionnary data derived from
ipadic for use with MeCab.")
(license (license:non-copyleft "mecab-ipadic/COPYING"))))
+
+(define-public mecab-unidic
+ (package
+ (name "mecab-unidic")
+ (version "3.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://clrd.ninjal.ac.jp/unidic_archive/cwj/"
+ version "/unidic-cwj-" version ".zip"))
+ (sha256
+ (base32
+ "1z132p2q3bgchiw529j2d7dari21kn0fhkgrj3vcl0ncg2m521il"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan
+ '(("." "lib/mecab/dic"
+ #:include-regexp ("\\.bin$" "\\.def$" "\\.dic$" "dicrc")))))
+ (native-inputs (list unzip))
+ (home-page "https://clrd.ninjal.ac.jp/unidic/en/")
+ (synopsis "Dictionary data for MeCab")
+ (description "UniDic for morphological analysis is a dictionary for
+analysis with the morphological analyser MeCab, where the short units exported
+from the database are used as entries (heading terms).")
+ (license (list license:gpl2+ license:lgpl2.1 license:bsd-3))))