[bug#53609,v2,3/4] gnu: Add glibc-2.2.5.
Commit Message
* gnu/packages/commencement.scm (glibc-2.2.5): New variable.
---
gnu/packages/commencement.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
Comments
Ricardo Wurmus schreef op za 05-02-2022 om 01:08 [+0100]:
> + ((#:configure-flags flags '())
> + #~(let ((out (assoc-ref %outputs "out"))
(assoc-ref %outputs "out") -> #$output
> + (headers (assoc-ref %build-inputs "kernel-headers")))
> + `("--enable-shared"
> + "--enable-static"
> + "--disable-sanity-checks"
> + "--build=i686-unknown-linux-gnu"
> + "--host=i686-unknown-linux-gnu"
Given that it's always compiled for i686-linux, even on x86_64, should
#:system "i686-linux" be set be added to 'arguments', such that glibc-
2.2.5 only needs to be compiled once? Likewise for the
'glibc-mesboot0' package (on core-updates).
Greetings,
Maxime
@@ -3471,6 +3471,30 @@ (define glibc-final
,@(package-outputs glibc-final-with-bootstrap-bash))
,@(package-arguments glibc-final-with-bootstrap-bash)))))
+(define glibc-2.2.5
+ (package/inherit
+ glibc-mesboot0
+ (arguments
+ (substitute-keyword-arguments (package-arguments glibc-mesboot0)
+ ((#:configure-flags flags '())
+ #~(let ((out (assoc-ref %outputs "out"))
+ (headers (assoc-ref %build-inputs "kernel-headers")))
+ `("--enable-shared"
+ "--enable-static"
+ "--disable-sanity-checks"
+ "--build=i686-unknown-linux-gnu"
+ "--host=i686-unknown-linux-gnu"
+ ,(string-append "--with-headers=" headers "/include")
+ "--enable-static-nss"
+ "--without-__thread"
+ "--without-cvs"
+ "--without-gd"
+ "--without-tls"
+ ,(string-append "--prefix=" out))))))
+ (propagated-inputs `(("kernel-headers" ,linux-libre-headers)))
+ (native-inputs
+ (alist-delete "kernel-headers" (%boot-mesboot1-inputs)))))
+
(define/system-dependent gcc-boot0-wrapped
;; Make the cross-tools GCC-BOOT0 and BINUTILS-BOOT0 available under the
;; non-cross names.