[bug#53825,v3] gnu: Add sbase.
Commit Message
* gnu/packages/suckless.scm (sbase): New variable.
---
Hi,
Here is version 3 with the fix Xinglu mentioned.
I haven't tested all the binaries.
all best,
jgart
https://whereiseveryone.srht.site/
gemini://whereiseveryone.srht.site/
gnu/packages/suckless.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)
Comments
Hi,
jgart <jgart@dismail.de> writes:
> * gnu/packages/suckless.scm (sbase): New variable.
> ---
>
> Hi,
>
> Here is version 3 with the fix Xinglu mentioned.
>
> I haven't tested all the binaries.
>
> all best,
>
> jgart
>
> https://whereiseveryone.srht.site/
> gemini://whereiseveryone.srht.site/
I've adjusted it like so:
--8<---------------cut here---------------start------------->8---
modified gnu/packages/suckless.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;; Copyright © 2021 Nikolay Korotkiy <sikmir@disroot.org>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1011,19 +1012,19 @@ (define-public sbase
(base32 "119v1lpgsx8bx9h57wg454ddhzz2awqavl3wrn35a704vifg28g0"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; There are no tests.
- #:make-flags
- ,#~(list (string-append "CC=" #$(cc-for-target))
- (string-append "PREFIX=" #$output))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure))))
+ (list
+ #:tests? #f ;no test suite
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
(home-page "https://core.suckless.org/sbase/")
- (synopsis "Collection of Unix tools that are portable across unix-systems")
- (description
- "@command{sbase} is a collection of Unix tools that are portable across
- Unix-systems.")
- (license license:x11))))
+ (synopsis "Collection of UNIX tools")
+ (description "@command{sbase} is a collection of UNIX tools similar to those of GNU
+Coreutils, containing utilities commands such as @command{grep}, @command{cp},
+@command{rm}, etc.")
+ (license license:expat))))
(define-public scron
(package
--8<---------------cut here---------------end--------------->8---
Reverting the license to Expat as pointed by Maxime, fully capitalizing
UNIX, using a gexp for the phases and adding a few commands to the
description to give a better idea. I've also removed the bits "portable
across UNIX systems" as on Guix that's not useful (the tools are as
portable as Guix itself is).
Pushed as 5299628b90.
Thanks!
Maxim
@@ -988,6 +988,39 @@ (define-public snooze
running a command.")
(license license:cc0)))
+(define-public sbase
+ ;; There are no tagged releases.
+ (let ((commit "2c2a7f54ab55a022a617e510b6e00c3e2736fabd")
+ (revision "0"))
+ (package
+ (name "sbase")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://git.suckless.org/sbase/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "119v1lpgsx8bx9h57wg454ddhzz2awqavl3wrn35a704vifg28g0"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:make-flags
+ ,#~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://core.suckless.org/sbase/")
+ (synopsis "Collection of Unix tools that are portable across unix-systems")
+ (description
+ "@command{sbase} is a collection of Unix tools that are portable across
+ Unix-systems.")
+ (license license:x11))))
+
(define-public scron
(package
(name "scron")