[bug#56300] gnu: Added breeze-gtk package.
Commit Message
(I tried sending this message earlier today and had some issues. I
apologize in advance if both were successful.)
Some people like when GTK and Qt programs to have a consistent look. I
noticed the GTK port of the Breeze theme was missing from the repos, so
this is adding it.
I am unsure about the licensing as their current repo mentions both the
LGPL 2.1 and BSD 3-clause. How should I set it properly? Is just LGPL
2.1 enough?
---
gnu/packages/kde-plasma.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
[ 2-line signature. Click/Enter to show. ]
Comments
Re: the licence: you could specify only lgpl2.1 as that's the result of combining lgpl2.1 with bsd-3, but you can also specify both in a (list ...) with comments next to each one to explain what applies to which file(s).
I prefer the latter but neither is wrong.
Kind regards,
T G-R
Sent on the go. Excuse or enjoy my brevity.
Hi Tobias,
Tobias Geerinckx-Rice (2022-06-29 18:21 +0000):
> Re: the licence: you could specify only lgpl2.1 as that's the result
> of combining lgpl2.1 with bsd-3, but you can also specify both in a
> (list ...) with comments next to each one to explain what applies to
> which file(s).
I prepared a new patch, but accidentally submitted it as a new issue on
its own (id 56321). Should I merge it here or do I merge this older one
there?
Best,
Samuel
Hi Samuel,
On 2022-07-05 15:45, Samuel Fadel wrote:
> I prepared a new patch, but accidentally submitted it as a new issue on
> its own (id 56321). Should I merge it here or do I merge this older one
> there?
There's no difference (but thanks for asking). Merging is symmetric,
order doesn't matter, both bugs become synonymous[0].
Kind regards,
T G-R
Sent from a Web browser. Excuse or enjoy my brevity.
[0]: https://debbugs.gnu.org/server-control.html
@@ -83,6 +83,31 @@ (define-public breeze
the Plasma Desktop. Breeze is the default theme for the KDE Plasma desktop.")
(license license:gpl2+)))
+(define-public breeze-gtk
+ (package
+ (name "breeze-gtk")
+ (version "5.19.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/" version "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1j2nq9yw1ragmgwrz9f6ca4ifpi86qv1bbprdgd2qm2yh7vb44sj"))))
+ (build-system qt-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)))) ; Test phase not defined
+ (native-inputs
+ (list breeze extra-cmake-modules sassc python python-pycairo))
+ (home-page "https://invent.kde.org/plasma/breeze")
+ (synopsis "Default KDE Plasma theme (GTK+ port)")
+ (description "GTK+ port of the Breeze visual style for the Plasma Desktop.
+Breeze is the default theme for the KDE Plasma desktop.")
+ (license license:lgpl2.1)))
+
+
(define-public kdecoration
(package
(name "kdecoration")