[bug#56181] gnu: packages: qbe: Update to 1.0.
Commit Message
* gnu/packages/c.scm (qbe): Update to 1.0.
---
gnu/packages/c.scm | 72 ++++++++++++++++++++++------------------------
1 file changed, 35 insertions(+), 37 deletions(-)
Comments
Am Freitag, dem 24.06.2022 um 07:04 +0100 schrieb (:
> * gnu/packages/c.scm (qbe): Update to 1.0.
> ---
> gnu/packages/c.scm | 72 ++++++++++++++++++++++------------------------
> 1 file changed, 35 insertions(+), 37 deletions(-)
>
> diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
> index 3e49539473..2dc8adb895 100644
> --- a/gnu/packages/c.scm
> +++ b/gnu/packages/c.scm
> @@ -147,44 +147,42 @@ (define-public pcc
> (license (list license:bsd-2 license:bsd-3))))
>
> (define-public qbe
> - (let ((commit "2caa26e388b1c904d2f12fb09f84df7e761d8331")
> - (revision "1"))
> - (package
> - (name "qbe")
> - (version (git-version "0.0" revision commit))
> - (source (origin
> - (method git-fetch)
> - (uri (git-reference
> - (url "git://c9x.me/qbe")
> - (commit commit)))
> - (file-name (git-file-name name version))
> - (sha256
> - (base32
> -
> "1gv03ym0gqrl4wkbhysa82025xwrkr1fg44z814b6vnggwlqgljc"))))
> - (build-system gnu-build-system)
> - (arguments
> - (list #:make-flags
> - #~(list (string-append "CC=" #$(cc-for-target))
> - (string-append "PREFIX=" #$output))
> - #:phases
> - #~(modify-phases %standard-phases
> - (add-after 'unpack 'allow-cross-compilation
> - (lambda _
> - (substitute* "Makefile"
> - (("`uname -m`") #$(or (%current-target-system)
> - (%current-system))))))
> - (add-after 'allow-cross-compilation 'use-$CC-for-
> tests
> - (lambda _
> - (substitute* "tools/test.sh"
> - (("cc=\"cc -no-pie\"") "cc=\"${CC} -no-
> pie\""))))
> - (delete 'configure))))
> - (supported-systems (list "x86_64-linux" "aarch64-linux"
> "riscv64-linux"))
> - (synopsis "Simple compiler backend")
> - (description
> - "QBE is a small compiler backend using an SSA-based
> intermediate
> + (package
> + (name "qbe")
> + (version "1.0")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "git://c9x.me/qbe")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> +
> "0qx4a3fjjrp2m4dsn19rpbjf89k9w7w7l09s96jx8vv15vzsdgis"))))
> + (build-system gnu-build-system)
> + (arguments
> + (list #:make-flags
> + #~(list (string-append "CC=" #$(cc-for-target))
> + (string-append "PREFIX=" #$output))
> + #:phases
> + #~(modify-phases %standard-phases
> + (add-after 'unpack 'allow-cross-compilation
> + (lambda _
> + (substitute* "Makefile"
> + (("`uname -m`") #$(or (%current-target-system)
> + (%current-system))))))
> + (add-after 'allow-cross-compilation 'use-$CC-for-tests
> + (lambda _
> + (substitute* "tools/test.sh"
> + (("cc=\"cc -no-pie\"") "cc=\"${CC} -no-pie\""))))
I'm pretty sure you can drop this phase as of [1]. Nice to know that
Gentoo folk have our back.
> + (delete 'configure))))
> + (supported-systems (list "x86_64-linux" "aarch64-linux" "riscv64-
> linux"))
> + (synopsis "Simple compiler backend")
> + (description
> + "QBE is a small compiler backend using an SSA-based intermediate
> language as input.")
> - (home-page "https://c9x.me/compile/")
> - (license license:expat))))
> + (home-page "https://c9x.me/compile/")
> + (license license:expat)))
Otherwise LGTM.
Cheers
[1]
https://c9x.me/git/qbe.git/commit/?id=2b451a28d8e98d5919e94dd611a8d9c66a9396af
On Fri Jun 24, 2022 at 7:17 AM BST, Liliana Marie Prikler wrote:
> I'm pretty sure you can drop this phase as of [1]. Nice to know that
> Gentoo folk have our back.
Oh, nice catch!
-- (
@@ -147,44 +147,42 @@ (define-public pcc
(license (list license:bsd-2 license:bsd-3))))
(define-public qbe
- (let ((commit "2caa26e388b1c904d2f12fb09f84df7e761d8331")
- (revision "1"))
- (package
- (name "qbe")
- (version (git-version "0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "git://c9x.me/qbe")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1gv03ym0gqrl4wkbhysa82025xwrkr1fg44z814b6vnggwlqgljc"))))
- (build-system gnu-build-system)
- (arguments
- (list #:make-flags
- #~(list (string-append "CC=" #$(cc-for-target))
- (string-append "PREFIX=" #$output))
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'allow-cross-compilation
- (lambda _
- (substitute* "Makefile"
- (("`uname -m`") #$(or (%current-target-system)
- (%current-system))))))
- (add-after 'allow-cross-compilation 'use-$CC-for-tests
- (lambda _
- (substitute* "tools/test.sh"
- (("cc=\"cc -no-pie\"") "cc=\"${CC} -no-pie\""))))
- (delete 'configure))))
- (supported-systems (list "x86_64-linux" "aarch64-linux" "riscv64-linux"))
- (synopsis "Simple compiler backend")
- (description
- "QBE is a small compiler backend using an SSA-based intermediate
+ (package
+ (name "qbe")
+ (version "1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://c9x.me/qbe")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qx4a3fjjrp2m4dsn19rpbjf89k9w7w7l09s96jx8vv15vzsdgis"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'allow-cross-compilation
+ (lambda _
+ (substitute* "Makefile"
+ (("`uname -m`") #$(or (%current-target-system)
+ (%current-system))))))
+ (add-after 'allow-cross-compilation 'use-$CC-for-tests
+ (lambda _
+ (substitute* "tools/test.sh"
+ (("cc=\"cc -no-pie\"") "cc=\"${CC} -no-pie\""))))
+ (delete 'configure))))
+ (supported-systems (list "x86_64-linux" "aarch64-linux" "riscv64-linux"))
+ (synopsis "Simple compiler backend")
+ (description
+ "QBE is a small compiler backend using an SSA-based intermediate
language as input.")
- (home-page "https://c9x.me/compile/")
- (license license:expat))))
+ (home-page "https://c9x.me/compile/")
+ (license license:expat)))
(define-public python-pcpp
(package