[bug#55864] Added the emacs-org-auto-tangle package
Commit Message
Good Morning/Afternoon,
Here is a patch to add the Emacs Orgmode package specialized for lazy
people (org-auto-tangle).
Please let me know if there's any way this package definition can be improved!
Regards,
Haider.
Comments
Hello, Haider
Am Mittwoch, dem 08.06.2022 um 22:34 +0100 schrieb Haider Mirza:
> [PATCH] Added the emacs-org-auto-tangle package
>
> ---
You're missing a ChangeLog here. Note that with magit+yasnippet you
can generate such commit messages "automatically" after loading the
snippet definitions from /path/to/guix/etc/snippets. Simply type
"add", then TAB.
> + (build-system emacs-build-system)
> + (propagated-inputs
> + (list emacs-async))
This indentation appears off, also you can squash propagated-inputs
into a single line.
> + (description
> + "This package (i.e org-auto-tangle) is a very simple emacs
> package that allows you to automatically tangle org files on save.")
"This package" is enough of a qualifier. Alternatively, write
@code{org-auto-tangle}. "is a very simple emacs package that" is very
useless filler. Write "This package allows you..." or similar. Note
the value of fill-column as per .dir-locals.el
Cheers
From c78b82bce0c2e77369db9432826c34d5d228734d Mon Sep 17 00:00:00 2001
From: Haider Mirza <x7and7@gmail.com>
Date: Wed, 8 Jun 2022 22:14:56 +0100
Subject: [PATCH] Added the emacs-org-auto-tangle package
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
@@ -113,6 +113,7 @@
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;; Copyright © 2022 Luis Felipe López Acevedo <luis.felipe.la@protonmail.com>
;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
+;;; Copyright © 2022 Haider Mirza <haider@haider.gq>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5486,6 +5487,27 @@ (define-public emacs-org-inline-pdf
inline PDF preview in Org buffers by using pdf2svg.")
(license license:gpl3+)))
+(define-public emacs-org-auto-tangle
+ (package
+ (name "emacs-org-auto-tangle")
+ (version "0.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/yilkalargaw/org-auto-tangle.git")
+ (commit version)))
+ (sha256
+ (base32
+ "1zb7vcmhmjiqpbbhqrqci689rnpn10p985cs5jk9sgg66xsbrgs3"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-async))
+ (home-page "https://github.com/yilkalargaw/org-auto-tangle")
+ (synopsis "Automatically tangle code blocks on save")
+ (description
+ "This package (i.e org-auto-tangle) is a very simple emacs package that allows you to automatically tangle org files on save.")
+ (license license:bsd-2)))
+
(define-public emacs-org-rich-yank
(package
(name "emacs-org-rich-yank")
--
2.36.1