diff mbox series

[bug#72713] gnu: Add r-cca.

Message ID 0a3b40feff33c9e3e5804df87165984b45797964.1724080499.git.Navid.Afkhami@mdc-berlin.de
State New
Headers show
Series [bug#72713] gnu: Add r-cca. | expand

Commit Message

Navid Afkhami Aug. 19, 2024, 3:14 p.m. UTC
* gnu/packages/cran.scm (r-cca): New variable.

Change-Id: Icc3411c5b57e97d8fc9f6e749f280b62572c32b3
---
 gnu/packages/cran.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: d3832de763777759eb1f56e20731cb39da4c7b5b

Comments

Ricardo Wurmus Nov. 1, 2024, 11:23 a.m. UTC | #1
Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3f964857ff..a9298e90b7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -41977,6 +41977,28 @@  (define-public r-mmwrweek
 convert dates to MMWR day, week, and year and the reverse.")
     (license license:gpl2+)))
 
+(define-public r-cca
+  (package
+    (name "r-cca")
+    (version "1.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "CCA" version))
+       (sha256
+        (base32 "0r1f7m64608hq6bpw36wsw6fr4s8bj26x4062brqgn5dbpqlgczk"))))
+    (properties `((upstream-name . "CCA")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-fda r-fields))
+    (home-page "https://cran.r-project.org/package=CCA")
+    (synopsis "Canonical correlation analysis")
+    (description
+     "This package contains a set of functions that extend the cancor function.
+These functions provide new numerical and graphical outputs.  It also include a
+regularized extension of the canonical correlation analysis to deal with
+datasets with more variables than observations.")
+    (license license:gpl2+)))
+
 (define-public r-cccd
   (package
     (name "r-cccd")