diff mbox series

[bug#74020] gnu: yoshimi: Fix build.

Message ID fee9558c12edfb32186161e0877890edecba3114.1729892147.git.goodoldpaul@autistici.org
State New
Headers show
Series [bug#74020] gnu: yoshimi: Fix build. | expand

Commit Message

Giacomo Leidi Oct. 25, 2024, 9:35 p.m. UTC
yoshimi was failing because it was trying to create a directory inside
the lv2 store tree.

* gnu/packages/music.scm (yoshimi)[arguments]<configure-flags>:
Explicitly set LV2_INSTALL_DIR.

Change-Id: I697ba879e8633bee99fdfad1e876beca33d114f8
---
 gnu/packages/music.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)


base-commit: a1714de3aa4f60d211c166876c3515f96384b0c7

Comments

Artyom V. Poptsov Oct. 26, 2024, 7:45 p.m. UTC | #1
Giacomo Leidi, thank you for the patch!

Merged to the "master" branch as
269e4034fcaf55324187efffb6ed5ba14d5e9286.

- avp
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 548836abeb..2f1b446504 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -27,7 +27,7 @@ 
 ;;; Copyright © 2019, 2020, 2021 Alexandros Theodotou <alex@zrythm.org>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2020 Lars-Dominik Braun <lars@6xq.net>
-;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020, 2024 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2020, 2022, 2023 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2020, 2022 Marius Bakke <marius@gnu.org>
@@ -3461,7 +3461,9 @@  (define-public yoshimi
      (list
       #:tests? #f                       ; there are no tests
       #:configure-flags
-      #~(list (string-append "-DCMAKE_INSTALL_DATAROOTDIR="
+      #~(list (string-append "-DLV2_INSTALL_DIR="
+                             #$output "/lib/lv2")
+              (string-append "-DCMAKE_INSTALL_DATAROOTDIR="
                              #$output "/share"))
       #:phases
       #~(modify-phases %standard-phases