diff mbox series

[bug#73338,2/2] gnu: impressive: Update to 13.2 and fix build

Message ID 20240918211510.468854-2-aaron.covrig.us@ieee.org
State New
Headers show
Series [bug#73339,1/2] gnu: pypandoc: Update to 1.13 and fix dependencies | expand

Commit Message

Aaron Covrig Sept. 18, 2024, 9:14 p.m. UTC
* gnu/packages/pdf.scm (impressive): Update to 13.2
[inputs]: depends on fixed python-pypandoc from prior commit
---
 gnu/packages/pdf.scm | 59 ++++++++++++++++++++++----------------------
 1 file changed, 29 insertions(+), 30 deletions(-)

Comments

Aaron Covrig Sept. 23, 2024, 10:38 p.m. UTC | #1
Looks like I messed up the multipart submission, this patch depends on
https://issues.guix.gnu.org/73339 (python-pypandoc)
Aaron Covrig Oct. 24, 2024, 9:28 p.m. UTC | #2
merge 73338 73339
diff mbox series

Patch

diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index e743d51286..8efff540df 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -28,6 +28,7 @@ 
 ;;; Copyright © 2024 dan <i@dan.games>
 ;;; Copyright © 2023 Benjamin Slade <slade@lambda-y.net>
 ;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1171,39 +1172,37 @@  (define-public python-reportlab
 (define-public impressive
   (package
     (name "impressive")
-    (version "0.13.1")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "mirror://sourceforge/impressive/Impressive/"
-                    version "/Impressive-" version ".tar.gz"))
-              (sha256
-               (base32
-                "0d1d2jxfl9vmy4swcdz660xd4wx91w1i3n07k522pccapwxig294"))))
+    ;; (version "0.13.1")
+    (version "0.13.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/impressive/Impressive/"
+                           version "/Impressive-" version ".tar.gz"))
+       (sha256
+        (base32
+         ;; "0d1d2jxfl9vmy4swcdz660xd4wx91w1i3n07k522pccapwxig294"))))
+         "0g15q67f992prkjndrk75hhd601iypfmkafhdx7hijs2byr26c83"))))
     (build-system python-build-system)
     (arguments
      (list
-      #:phases
-      #~(modify-phases %standard-phases
-          (delete 'build)
-          (delete 'configure)
-          (delete 'check)
-          (replace 'install
-            (lambda* (#:key inputs #:allow-other-keys)
-              ;; There's no 'setup.py' so install things manually.
-              (let* ((bin  (string-append #$output "/bin"))
-                     (impressive (string-append bin "/impressive"))
-                     (man1 (string-append #$output "/share/man/man1")))
-                (mkdir-p bin)
-                (copy-file "impressive.py" impressive)
-                (chmod impressive #o755)
-                (wrap-program (string-append bin "/impressive")
-                  `("LIBRARY_PATH" ":" prefix ;for ctypes
-                    (,(string-append #$(this-package-input "sdl")
-                                     "/lib")))
-                  `("PATH" ":" prefix   ;for pdftoppm
-                    (,(search-input-file inputs "bin/xpdf"))))
-                (install-file "impressive.1" man1)))))))
+      #:phases #~(modify-phases %standard-phases
+                   (delete 'build)
+                   (delete 'configure)
+                   (delete 'check)
+                   (replace 'install
+                     (lambda* (#:key inputs #:allow-other-keys)
+                       ;; There's no 'setup.py' so install things manually.
+                       (let* ((bin (string-append #$output "/bin"))
+                              (impressive (string-append bin "/impressive"))
+                              (man1 (string-append #$output "/share/man/man1")))
+                         (mkdir-p bin)
+                         (copy-file "impressive.py" impressive)
+                         (chmod impressive #o755)
+                         (wrap-program (string-append bin "/impressive")
+                           `("PATH" ":" prefix ;for pdftoppm
+                             (,(search-input-file inputs "bin/xpdf"))))
+                         (install-file "impressive.1" man1)))))))
     ;; TODO: Add dependency on pdftk.
     (inputs (list bash-minimal python-pygame python-pillow sdl xpdf))
     (home-page "https://impressive.sourceforge.net")