diff mbox series

[bug#73888] gnu: fabla: Update to 1.4.

Message ID 53227d3b3bfc89308c144c78e88ef80298c78c09.1729355371.git.poptsov.artyom@gmail.com
State New
Headers show
Series [bug#73888] gnu: fabla: Update to 1.4. | expand

Commit Message

Artyom V. Poptsov Oct. 19, 2024, 4:29 p.m. UTC
* gnu/packages/music.scm (fabla): Update to 1.4.

Change-Id: I3fbba9df343ad296a78f2e54fbe02a525a1d546f
---
 gnu/packages/music.scm | 46 +++++++++++++++++++-----------------------
 1 file changed, 21 insertions(+), 25 deletions(-)


base-commit: 5794926bed6fad4598bb565fb7f49be4205b11a1

Comments

Ludovic Courtès Oct. 23, 2024, 10:59 a.m. UTC | #1
"Artyom V. Poptsov" <poptsov.artyom@gmail.com> skribis:

> * gnu/packages/music.scm (fabla): Update to 1.4.
>
> Change-Id: I3fbba9df343ad296a78f2e54fbe02a525a1d546f

LGTM!
Artyom V. Poptsov Oct. 23, 2024, 9:53 p.m. UTC | #2
Merged into "master" branch as 414d6d7f3234e6230366b2f6edc32b4060f01aee.

- avp
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 9c1a617ca1..548836abeb 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5813,32 +5813,28 @@  (define-public luppp
       (license license:gpl3+))))
 
 (define-public fabla
-  (let ((revision "1")
-        ;; The last release was in 2016.  Since then a number of commits have
-        ;; been added to fix build problems.
-        (commit "10acf03046d980f96ed192d5acb9deb812f5c639"))
-    (package
-      (name "fabla")
-      (version (git-version "1.3.2" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/openAVproductions/openAV-Fabla")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0ybbzb86j1n5dfhzc6aa3cibkwi6q3x0c18b1w3anyibanmr1wmc"))))
-      (build-system cmake-build-system)
-      (arguments '(#:tests? #f)) ;there are none
-      (inputs (list ntk cairomm libsndfile))
-      (native-inputs (list pkg-config lv2 mesa))
-      (home-page "http://openavproductions.com/fabla/")
-      (synopsis "Sampler LV2 plugin")
-      (description
-       "Fabla is an LV2 drum sampler plugin instrument.  It is ideal for loading up
+  (package
+    (name "fabla")
+    (version "1.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/openAVproductions/openAV-Fabla")
+                    (commit (string-append "release-" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "13675ljfcbmxw9jdjrpn9wpvl69qxxc1hg2y9sfjkf4khajpapg9"))))
+    (build-system cmake-build-system)
+    (arguments '(#:tests? #f)) ;there are none
+    (inputs (list ntk cairomm libsndfile))
+    (native-inputs (list pkg-config lv2 mesa))
+    (home-page "http://openavproductions.com/fabla/")
+    (synopsis "Sampler LV2 plugin")
+    (description
+     "Fabla is an LV2 drum sampler plugin instrument.  It is ideal for loading up
 your favorite sampled sounds and bashing away on a MIDI controller.")
-      (license license:gpl2+))))
+    (license license:gpl2+)))
 
 (define-public sorcer
   (let ((revision "1")