diff mbox series

[bug#73887,v2] gnu: stklos: Update to 2.10.

Message ID 60cc7284d504d1eac613a26e41a46256855960f6.1729364571.git.ashish.is@lostca.se
State New
Headers show
Series [bug#73887,v2] gnu: stklos: Update to 2.10. | expand

Commit Message

Ashish SHUKLA Oct. 19, 2024, 7:02 p.m. UTC
* gnu/packages/scheme.scm (stklos): Update to 2.10.
[inputs]: Add gmp, libgc, pcre2, libffi, and readline.
[native-inputs]: Add pkg-config.
[arguments]<#:configure-flags>: set LDFLAGS flag.

Change-Id: Ife374dd60ef17129fa88b7a0940ab914e7b3c396
Co-authored-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
---
Hi,

Thanks for reviewing the diff. Update diff according to suggestions, and
added credit for the same.

Thanks!

 gnu/packages/scheme.scm | 11 +++++++++--
 1 file changed, 9 insertions(+), 2 deletions(-)


base-commit: e951a375a01262dfd470ee343baf7c41dbc6ff58

Comments

Z572 Oct. 20, 2024, 2:33 p.m. UTC | #1
Ashish SHUKLA via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/scheme.scm (stklos): Update to 2.10.
> [inputs]: Add gmp, libgc, pcre2, libffi, and readline.
> [native-inputs]: Add pkg-config.
> [arguments]<#:configure-flags>: set LDFLAGS flag.
>
> Change-Id: Ife374dd60ef17129fa88b7a0940ab914e7b3c396
> Co-authored-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
> ---
> Hi,
>
> Thanks for reviewing the diff. Update diff according to suggestions, and
> added credit for the same.
>
> Thanks!
>
>  gnu/packages/scheme.scm | 11 +++++++++--
>  1 file changed, 9 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
> index 6f9d00e440..0d6a662aaa 100644
> --- a/gnu/packages/scheme.scm
> +++ b/gnu/packages/scheme.scm
> @@ -86,6 +86,7 @@ (define-module (gnu packages scheme)
>    #:use-module (gnu packages netpbm)
>    #:use-module (gnu packages pcre)
>    #:use-module (gnu packages pkg-config)
> +  #:use-module (gnu packages readline)
>    #:use-module (gnu packages sqlite)
>    #:use-module (gnu packages tex)
>    #:use-module (gnu packages texinfo)
> @@ -1275,7 +1276,7 @@ (define-public emacs-gerbil-mode
>  (define-public stklos
>    (package
>      (name "stklos")
> -    (version "1.70")
> +    (version "2.10")
>      (source (origin
>                (method url-fetch)
>                ;; TODO: Unbundle pcre, libgc, and libffi.
> @@ -1283,12 +1284,18 @@ (define-public stklos
>                                    version ".tar.gz"))
>                (sha256
>                 (base32
> -                "1iw3pgycjz3kz3jd1855v2ngf8ib2almpf8v058n1mkj1qd2b88m"))))
> +                "0hd05r5pr3yhgq44n5sqdmvkpgnhf5fybmis2g3gwj10z52h7gvd"))))
>      (build-system gnu-build-system)
> +    (native-inputs (list pkg-config))
> +    (inputs (list gmp libgc pcre2 libffi readline))
>      (arguments
>       (list
>        #:modules `((ice-9 ftw)
>                    ,@%default-gnu-modules)
> +      #:configure-flags
> +      #~(list (string-append "LDFLAGS=-L"
> +                #$(this-package-input "readline")
> +                "/lib -lreadline"))
>        #:phases
>        #~(modify-phases %standard-phases
>            (add-before 'configure 'patch-sh-references
>
> base-commit: e951a375a01262dfd470ee343baf7c41dbc6ff58

push, close.
diff mbox series

Patch

diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 6f9d00e440..0d6a662aaa 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -86,6 +86,7 @@  (define-module (gnu packages scheme)
   #:use-module (gnu packages netpbm)
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages readline)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages tex)
   #:use-module (gnu packages texinfo)
@@ -1275,7 +1276,7 @@  (define-public emacs-gerbil-mode
 (define-public stklos
   (package
     (name "stklos")
-    (version "1.70")
+    (version "2.10")
     (source (origin
               (method url-fetch)
               ;; TODO: Unbundle pcre, libgc, and libffi.
@@ -1283,12 +1284,18 @@  (define-public stklos
                                   version ".tar.gz"))
               (sha256
                (base32
-                "1iw3pgycjz3kz3jd1855v2ngf8ib2almpf8v058n1mkj1qd2b88m"))))
+                "0hd05r5pr3yhgq44n5sqdmvkpgnhf5fybmis2g3gwj10z52h7gvd"))))
     (build-system gnu-build-system)
+    (native-inputs (list pkg-config))
+    (inputs (list gmp libgc pcre2 libffi readline))
     (arguments
      (list
       #:modules `((ice-9 ftw)
                   ,@%default-gnu-modules)
+      #:configure-flags
+      #~(list (string-append "LDFLAGS=-L"
+                #$(this-package-input "readline")
+                "/lib -lreadline"))
       #:phases
       #~(modify-phases %standard-phases
           (add-before 'configure 'patch-sh-references