diff mbox series

[bug#72712] gnu: glfw: Fix a missing path to a dlopen call.

Message ID 68942320.44677372.1724075387309.JavaMail.root@zimbra81-e14.priv.proxad.net
State New
Headers show
Series [bug#72712] gnu: glfw: Fix a missing path to a dlopen call. | expand

Commit Message

arnaud.lechevallier@free.fr Aug. 19, 2024, 1:49 p.m. UTC
Hello,

Recent release of glfw introduced a new dlopen call to `libwayland-client.so.0'. I made a patch to add this new library into the list of libraries to be patched by the existing macro `patch-sonames'.
It will have no effect on previous glfw-3.3.10 but it will fix later version such as the new definition package provided for glfw-3.4.

Kind regards,

Arnaud.

Comments

Z572 Sept. 24, 2024, 3:08 p.m. UTC | #1
arnaud.lechevallier@free.fr writes:

> Hello,
>
> Recent release of glfw introduced a new dlopen call to `libwayland-client.so.0'. I made a patch to add this new library into the list of libraries to be patched by the existing macro `patch-sonames'.
> It will have no effect on previous glfw-3.3.10 but it will fix later version such as the new definition package provided for glfw-3.4.
>
> Kind regards,
>
> Arnaud.
>
> [2. text/x-patch; 0001-gnu-glfw-Fix-a-missing-path-to-a-dlopen-call.patch]...

thanks!

push and close.
diff mbox series

Patch

From 2d146872772ec3aebe30d7b28be947a12f0ea6f5 Mon Sep 17 00:00:00 2001
Message-ID: <2d146872772ec3aebe30d7b28be947a12f0ea6f5.1724074469.git.arnaud.lechevallier@free.fr>
From: Arnaud Lechevallier <arnaud.lechevallier@free.fr>
Date: Mon, 19 Aug 2024 14:59:02 +0200
Subject: [PATCH] gnu: glfw: Fix a missing path to a dlopen call.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Recent release of glfw introduced a new dlopen call to `libwayland-client.so.0´.
This small fix adds this library to the list of libraries to be patched. It
does not affect earlier versions.

* gnu/packages/gl.scm (glfw): Add `libwayland-client.so.0' to the list of
libraries to be patched.

Change-Id: I9436c63f49a9b2fed18e06d593e67a593e3c6cad
---
 gnu/packages/gl.scm | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 8441f3ae65..72b8d190e7 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -21,6 +21,7 @@ 
 ;;; Copyright © 2023, 2024 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2024 Liliana Marie Prikler <liliana.prikler@gmail.com>
 ;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2024 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -968,6 +969,7 @@  (define-public glfw
                                "libvulkan.so.1"
                                "libwayland-cursor.so.0"
                                "libwayland-egl.so.1"
+                               "libwayland-client.so.0"
                                "libxkbcommon.so.0"
                                "libXxf86vm.so.1"
                                "libXi.so.6"

base-commit: 71f0676a295841e2cc662eec0d3e9b7e69726035
-- 
2.45.2