diff mbox series

[bug#73339,1/2] gnu: pypandoc: Update to 1.13 and fix dependencies

Message ID 20240918211510.468854-1-aaron.covrig.us@ieee.org
State New
Headers show
Series [bug#73339,1/2] gnu: pypandoc: Update to 1.13 and fix dependencies | expand

Commit Message

Aaron Covrig Sept. 18, 2024, 9:14 p.m. UTC
* gnu/packages/python-xyz.scm (pypandoc): Update to 1.13
[inputs]: Add texlive-xpatch
---
 gnu/packages/python-xyz.scm | 39 ++++++++++++++++++++-----------------
 1 file changed, 21 insertions(+), 18 deletions(-)


base-commit: 1b6ce1796abdf497f61f426d61339318f4f4f23d

Comments

Aaron Covrig Sept. 23, 2024, 10:36 p.m. UTC | #1
It would seem I did not do the multipart commit correctly, this issue
is the part 1/2
for https://issues.guix.gnu.org/73338; hopefully this one for pypandoc gets pickedup first by the build system.
Aaron Covrig Oct. 24, 2024, 9:28 p.m. UTC | #2
merge 73338 73339
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8d402d4f94..055faef0de 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -155,6 +155,7 @@ 
 ;;; Copyright © 2024 David Elsing <david.elsing@posteo.net>
 ;;; Copyright © 2024 Rick Huijzer <ikbenrickhuyzer@gmail.com>
 ;;; Copyright © 2024 Peter Kannewitz <petre-vps@posteo.net>
+;;; Copyright © 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -32381,31 +32382,33 @@  (define-public python-safety
 (define-public python-pypandoc
   (package
     (name "python-pypandoc")
-    (version "1.7.5")
+    (version "1.13")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pypandoc" version))
        (sha256
-        (base32
-         "0l6a8ngzpx363q2jskxxkx6psfhqrvc4js80dmn16r3vw6m2cb40"))))
+        (base32 "07hw2psqzaffskmgb789f0zbra9cc17ykl8baw1jn34nqxrj0r9i"))))
     (build-system python-build-system)
-    (inputs
-     (list pandoc python-pandocfilters))
-    (propagated-inputs
-     `(("wheel" ,python-wheel)))
-    (native-inputs
-     `(("texlive" ,(texlive-updmap.cfg (list texlive-lm texlive-xcolor)))))
+    (inputs (list pandoc python-pandocfilters texlive-xpatch))
+    (propagated-inputs `(("wheel" ,python-wheel)))
+    (native-inputs `(("texlive" ,(texlive-updmap.cfg (list texlive-lm
+                                                           texlive-xcolor)))))
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'disable-tests
-           (lambda _
-             ;; Disable test requiring network access
-             (substitute* "tests.py"
-               (("test_basic_conversion_from_http_url")
-                "skip_test_basic_conversion_from_http_url"))
-             #t)))))
+     `(#:phases (modify-phases %standard-phases
+                  (add-before 'check 'disable-tests
+                    (lambda _
+                      (substitute* "tests.py"
+                        ;; Disable test requiring network access
+                        (("test_basic_conversion_from_http_url")
+                         "skip_test_basic_conversion_from_http_url")
+                        ;; Disable tests with missing files
+                        (("test_basic_conversion_from_file_pattern")
+                         "skip_test_basic_conversion_from_file_pattern")
+                        (("test_conversion_with_data_files")
+                         "skip_test_conversion_with_data_files")
+                        (("test_conversion_stderr")
+                         "skip_test_conversion_stderr")) #t)))))
     (home-page "https://github.com/bebraw/pypandoc")
     (synopsis "Python wrapper for pandoc")
     (description "pypandoc is a thin Python wrapper around pandoc