diff mbox series

[bug#72957] gnu: Add bin-graph.

Message ID 1441b8dd251c1fe66966d807a6f663ca2700f9c6.1725271047.git.poptsov.artyom@gmail.com
State New
Headers show
Series [bug#72957] gnu: Add bin-graph. | expand

Commit Message

Artyom V. Poptsov Sept. 2, 2024, 9:57 a.m. UTC
* gnu/packages/linux.scm (bin-graph): New variable.

Change-Id: I7405cbc00e038d024d035fb100473352c9a7b59d
---
 gnu/packages/linux.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)


base-commit: a977900d76b7585c401222a3ce8bbb82e5f6da45

Comments

Z572 Sept. 4, 2024, 2:43 a.m. UTC | #1
"Artyom V. Poptsov" <poptsov.artyom@gmail.com> writes:


maybe gnu/packages/graph.scm better here

> * gnu/packages/linux.scm (bin-graph): New variable.
>
> Change-Id: I7405cbc00e038d024d035fb100473352c9a7b59d
> ---
>  gnu/packages/linux.scm | 37 +++++++++++++++++++++++++++++++++++++
>  1 file changed, 37 insertions(+)
>
> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> index 318c6ccf13..38f3d6fc2f 100644
> --- a/gnu/packages/linux.scm
> +++ b/gnu/packages/linux.scm
> @@ -1776,6 +1776,43 @@ (define-public bbswitch-module
>  graphics card on Optimus laptops.")
>        (license license:gpl2))))
>  
> +(define-public bin-graph
> +  ;; XXX: The upstream does not have tags yet.
> +  (let ((commit "1dd42e3e8e123e993d6c287967502c8d4b36f9ba")
> +        (revision "0"))
> +    (package
> +      (name "bin-graph")
> +      (version (git-version "0.0.0" revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/8dcc/bin-graph")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32 "1wjkl789r7iys3nnyk813gsdxwwy2ryxgxirx5xw02lzk790dywl"))))
> +      (arguments
> +       (list #:tests? #f                ; no tests
> +             #:make-flags
> +             #~(list (string-append "CC=" #$(cc-for-target))
> +                     (string-append "PREFIX=" #$output))

see https://github.com/8dcc/bin-graph/blob/f5c53c427248d3fe10c1c921ea134f4592fbe8b7/Makefile#L10C1-L10C12

when use (string-append "INSTALL_DIR=" #$output "/bin") , not need to
replace install phase.

> +             #:phases
> +             #~(modify-phases %standard-phases
> +                 (delete 'configure)

please add a comment, ; no configure script

> +                 (replace 'install
> +                   (lambda _
> +                     (install-file "bin-graph"
> +                                   (string-append #$output "/bin")))))))
> +      (build-system gnu-build-system)
> +      (inputs (list libpng))
> +      (home-page "https://github.com/8dcc/bin-graph")
> +      (synopsis "Visualize binary files")
> +      (description
> +       "@code{bin-graph} provides a simple way of visualizing the different regions
> +of a binary file.")
> +      (license license:gpl3))))
> +
>  (define-public ddcci-driver-linux
>    (package
>      (name "ddcci-driver-linux")
>
> base-commit: a977900d76b7585c401222a3ce8bbb82e5f6da45
Artyom V. Poptsov Sept. 4, 2024, 7:46 a.m. UTC | #2
Hello, Zheng Junjie!

Thank you for the patch review!  I fixed most of the issues that you
mentioned.

> maybe gnu/packages/graph.scm better here

I don't think that "graph.scm" is a good place for "bin-graph" as this
is not a tool for working with images only but more like a tool for
visualizing the insides of binaries.  It's closer to reverse-engineering
realm than to image processing realm.

- avp
Andreas Enge Sept. 18, 2024, 8:53 a.m. UTC | #3
Hello Artyom,

it looks good and passes QA.

I think you have commit rights now and can push it yourself and close
the issue? If not, please come back to me.

Andreas
Artyom V. Poptsov Oct. 13, 2024, 10:17 a.m. UTC | #4
Pushed to the "master" as e4f5eb6c01727ef143e533019e74830e00d6f5d2.

- avp
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 318c6ccf13..38f3d6fc2f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1776,6 +1776,43 @@  (define-public bbswitch-module
 graphics card on Optimus laptops.")
       (license license:gpl2))))
 
+(define-public bin-graph
+  ;; XXX: The upstream does not have tags yet.
+  (let ((commit "1dd42e3e8e123e993d6c287967502c8d4b36f9ba")
+        (revision "0"))
+    (package
+      (name "bin-graph")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/8dcc/bin-graph")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1wjkl789r7iys3nnyk813gsdxwwy2ryxgxirx5xw02lzk790dywl"))))
+      (arguments
+       (list #:tests? #f                ; no tests
+             #:make-flags
+             #~(list (string-append "CC=" #$(cc-for-target))
+                     (string-append "PREFIX=" #$output))
+             #:phases
+             #~(modify-phases %standard-phases
+                 (delete 'configure)
+                 (replace 'install
+                   (lambda _
+                     (install-file "bin-graph"
+                                   (string-append #$output "/bin")))))))
+      (build-system gnu-build-system)
+      (inputs (list libpng))
+      (home-page "https://github.com/8dcc/bin-graph")
+      (synopsis "Visualize binary files")
+      (description
+       "@code{bin-graph} provides a simple way of visualizing the different regions
+of a binary file.")
+      (license license:gpl3))))
+
 (define-public ddcci-driver-linux
   (package
     (name "ddcci-driver-linux")