diff mbox series

[bug#73183] gnu: perl-gd: Use native perl-extutils-pkgconfig.

Message ID 20240911190019.26307-1-herman@rimm.ee
State New
Headers show
Series [bug#73183] gnu: perl-gd: Use native perl-extutils-pkgconfig. | expand

Commit Message

Herman Rimm Sept. 11, 2024, 7 p.m. UTC
* gnu/packages/gd.scm (perl-gd)[native-inputs]: Replace
perl-extutils-pkgconfig with %perl-extutils-pkgconfig.
---
 gnu/packages/gd.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès Sept. 17, 2024, 3:31 p.m. UTC | #1
Hi,

Herman Rimm <herman@rimm.ee> skribis:

> * gnu/packages/gd.scm (perl-gd)[native-inputs]: Replace
> perl-extutils-pkgconfig with %perl-extutils-pkgconfig.

[...]

>      (native-inputs
> -     (list perl-extutils-pkgconfig
> +      ;; Avoid error in pre-inst-env.  Cross-compilation is broken
> +      ;; anyway, so no big loss.
> +     (list %perl-extutils-pkgconfig

What error is this supposed to fix?

“./pre-inst-env guix build perl-gd” works for me.

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 98d34cfa71..6ebc871161 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -127,7 +127,9 @@  (define-public perl-gd
            libjpeg-turbo
            zlib))
     (native-inputs
-     (list perl-extutils-pkgconfig
+      ;; Avoid error in pre-inst-env.  Cross-compilation is broken
+      ;; anyway, so no big loss.
+     (list %perl-extutils-pkgconfig
            perl-test-nowarnings))
     (arguments
      (list #:make-maker-flags