diff mbox series

[bug#73213] gnu: Add go-github-com-jlaffaye-ftp.

Message ID 80457016560ad99aced6b7138b08020e845050fb.1726176920.git.poptsov.artyom@gmail.com
State New
Headers show
Series [bug#73213] gnu: Add go-github-com-jlaffaye-ftp. | expand

Commit Message

Artyom V. Poptsov Sept. 12, 2024, 9:35 p.m. UTC
* gnu/packages/golang-web.scm (go-github-com-jlaffaye-ftp): New variable.

Change-Id: I51dca96f5a3f224eb96feda1196bf18d0c174633
---
 gnu/packages/golang-web.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: 98bc13b9ea5f22a60de6c289d59072638001e08e

Comments

Sharlatan Hellseher Sept. 16, 2024, 9:42 p.m. UTC | #1
Hi,

Pushed as 3bcdb6a92e2ed49a4a0b290288e2bf052eddae57 to master.

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 2ff362fd8c..73a5bff348 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2528,6 +2528,30 @@  (define-public go-github-com-jhillyerd-enmime
 geared towards parsing MIME encoded emails.")
     (license license:expat)))
 
+(define-public go-github-com-jlaffaye-ftp
+  (package
+    (name "go-github-com-jlaffaye-ftp")
+    (version "0.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jlaffaye/ftp")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0z9d1dxhx351158a22a08qbnfql7a1cajg6v3zm82m2rnp17ahir"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/jlaffaye/ftp"))
+    (native-inputs (list go-github-com-stretchr-testify))
+    (propagated-inputs (list go-github-com-hashicorp-go-multierror))
+    (home-page "https://github.com/jlaffaye/ftp")
+    (synopsis "FTP client package for Go")
+    (description "A File Transfer Protocol (FTP) client package for Go")
+    (license license:isc)))
+
 (define-public go-github-com-jmespath-go-jmespath
   (package
     (name "go-github-com-jmespath-go-jmespath")