diff mbox series

[bug#73136] gnu: hut: Update to 0.6.0

Message ID CAFVS=zAdjA3bZHfwMFW-t-zB=+CsYidReGUxpEmGBKCMN4nZcw@mail.gmail.com
State New
Headers show
Series [bug#73136] gnu: hut: Update to 0.6.0 | expand

Commit Message

Javier Olaechea Sept. 9, 2024, 4:54 a.m. UTC
Hi,

The following patch updates hut to the latest version, 0.6.0. Between the
previous version and the current, a change of upstream happened. As well as
one new dependency and one less. See:

-
https://git.sr.ht/~emersion/hut/commit/82e6f9fd3a5eb9c4365af43a03aecb9d5ac2ea97
-
https://git.sr.ht/~xenrox/hut/commit/6c85e1e3726a54e10783db84d72e0eafa1428090
-
https://git.sr.ht/~xenrox/hut/commit/515e9299778c5a6bb2b23d0b69e427442691dfd1

Cheers

Comments

jgart Sept. 9, 2024, 6:54 p.m. UTC | #1
Hi Javier,

Thanks for your contribution. Can you see the commit style for updating
changes and send a v2?

TLDR IIRC:

[source]: Update url.
[arguments]: Update import path.
[inputs]: Remove go-golang-org-x-oauth2 and add go-github-com-google-shlex.
[home-page]: Update home-page.

See a previous commit with similar updates for the commit style.

Thanks!
Sharlatan Hellseher Sept. 16, 2024, 9:38 p.m. UTC | #2
Hi,

Pushed as 68ee1495aa1622462546b25ce4374882086f0128 to master.

--
Oleg
diff mbox series

Patch

From e563aaf4266718f7d2072104ca71e4f3de2f67fb Mon Sep 17 00:00:00 2001
Message-ID: <e563aaf4266718f7d2072104ca71e4f3de2f67fb.1725857053.git.pirata@gmail.com>
From: Javier Olaechea <pirata@gmail.com>
Date: Sun, 8 Sep 2024 23:38:03 -0500
Subject: [PATCH] gnu: hut: Update to 0.6.0

* gnu/packages/version-control.scm (hut): Update to 0.6.0

Updating to the new version required the following changes

- Change the package source to the new upstream, xenrox [0].
- Add a new dependency, google-shlex [1].
- Remove a dependency that was dropped, x/oauth2 [2].

[0]: https://git.sr.ht/~emersion/hut/commit/82e6f9fd3a5eb9c4365af43a03aecb9d5ac2ea97
[1]: https://git.sr.ht/~xenrox/hut/commit/6c85e1e3726a54e10783db84d72e0eafa1428090
[2]: https://git.sr.ht/~xenrox/hut/commit/515e9299778c5a6bb2b23d0b69e427442691dfd1

Change-Id: I64d2b068aedc12a41b695048fcb3fd329d82509f
---
 gnu/packages/version-control.scm | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 0c4cdedce8..3c671afd0f 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -4187,20 +4187,20 @@  (define-public gitlint
 (define-public hut
   (package
     (name "hut")
-    (version "0.4.0")
+    (version "0.6.0")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://git.sr.ht/~emersion/hut")
+             (url "https://git.sr.ht/~xenrox/hut")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0klp7qlii07j8ka9g91m5xg3ybg6cq0p5lp1ibfihq2p4kwqj57m"))))
+        (base32 "14cia976i2jdzyzw4wk9fhkh6zqgmb09ryf31ys24smmfcdfxyf1"))))
     (build-system go-build-system)
     (arguments
      (list
-      #:import-path "git.sr.ht/~emersion/hut"
+      #:import-path "git.sr.ht/~xenrox/hut"
       #:phases
       #~(modify-phases %standard-phases
           (replace 'build
@@ -4220,11 +4220,11 @@  (define-public hut
      (list go-git-sr-ht-emersion-go-scfg
            go-git-sr-ht-emersion-gqlclient
            go-github-com-dustin-go-humanize
+           go-github-com-google-shlex
            go-github-com-juju-ansiterm
            go-github-com-spf13-cobra
-           go-golang-org-x-oauth2
            go-golang-org-x-term))
-    (home-page "https://git.sr.ht/~emersion/hut")
+    (home-page "https://git.sr.ht/~xenrox/hut")
     (synopsis "CLI tool for sr.ht")
     (description "@command{hut} is a CLI tool for
 @uref{https://sr.ht/~sircmpwn/sourcehut/, sr.ht}.  It helps you interact with

base-commit: 056910ec864cb7cf3225a0c27679d94405db7dcd
-- 
2.45.2