diff mbox series

[bug#73163,v2] gnu: openpmix: Do not keep a reference to GCC and other build tools.

Message ID 2d318ad3d3887118448da393d57aaf4b722e52ec.1725958053.git.ludo@gnu.org
State New
Headers show
Series [bug#73163,v2] gnu: openpmix: Do not keep a reference to GCC and other build tools. | expand

Commit Message

Ludovic Courtès Sept. 10, 2024, 8:48 a.m. UTC
From: Ludovic Courtès <ludovic.courtes@inria.fr>

This reduces the closure of ‘openpmix’ from 297 MiB to 93 MiB.

* gnu/packages/parallel.scm (openpmix)[arguments]: Add #:phases
and #:disallowed-references.

Change-Id: I231c550743e2854e431b8100584bd464695de695
---
 gnu/packages/parallel.scm | 25 ++++++++++++++++++++++++-
 1 file changed, 24 insertions(+), 1 deletion(-)


base-commit: 637ca78f513fac15284403c0d3af64492ea832a1

Comments

Ludovic Courtès Sept. 16, 2024, 9:17 a.m. UTC | #1
Ludovic Courtès <ludo@gnu.org> skribis:

> From: Ludovic Courtès <ludovic.courtes@inria.fr>
>
> This reduces the closure of ‘openpmix’ from 297 MiB to 93 MiB.
>
> * gnu/packages/parallel.scm (openpmix)[arguments]: Add #:phases
> and #:disallowed-references.
>
> Change-Id: I231c550743e2854e431b8100584bd464695de695

Pushed as 3daab044145b4b39fe60c64e89f35e3b2a538935.
diff mbox series

Patch

diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index d5a55a8641..a77894b8d6 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -52,6 +52,7 @@  (define-module (gnu packages parallel)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages freeipmi)
+  #:use-module (gnu packages gcc)
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages maths)
@@ -646,7 +647,29 @@  (define-public openpmix
    (arguments
     (list #:configure-flags
           #~(list (string-append "--with-hwloc="
-                                 (ungexp (this-package-input "hwloc") "lib")))))
+                                 (ungexp (this-package-input "hwloc") "lib")))
+
+          ;; Don't keep a reference to GCC.
+          #:disallowed-references (and (not (%current-target-system))
+                                       (list (canonical-package gcc)))
+
+          #:phases
+          #~(modify-phases %standard-phases
+              (add-before 'configure 'strip-pmix-cc-absolute
+                (lambda _
+                  ;; The 'pmix_info' program prints the 'configure' command
+                  ;; line, compiler absolute file name, etc., which causes it
+                  ;; to keep references to many build-time packages.  Scrub
+                  ;; these.
+                  (substitute* "configure"
+                    (("PMIX_CC_ABSOLUTE=\"(.*)\"" _ cc)
+                     (string-append "PMIX_CC_ABSOLUTE=\"$(basename \""
+                                    cc "\")\"\n")))))
+              (add-after 'configure 'strip-pmix-config-header
+                (lambda _
+                  (substitute* "src/include/pmix_config.h"
+                    (("#define PMIX_CONFIGURE_CLI .*")
+                     "#define PMIX_CONFIGURE_CLI \"[scrubbed]\"\n")))))))
    (inputs (list libevent `(,hwloc "lib")))
    (native-inputs (list perl python))
    (synopsis "PMIx library")