diff mbox series

[bug#73200] gnu: sleef: Update to 3.6.1.

Message ID 48a6ec25807a4f19352e50b9b46df9f0d5b6fe11.1726154961.git.efraim@flashner.co.il
State New
Headers show
Series [bug#73200] gnu: sleef: Update to 3.6.1. | expand

Commit Message

Efraim Flashner Sept. 12, 2024, 3:29 p.m. UTC
* gnu/packages/maths.scm (sleef): Update to 3.6.1.
[arguments]: Set build-type to release.  Update configure-flags to only
set building a shared library.
[inputs]: Remove openssl-1.1.  Add mpfr, openssl.

Change-Id: I3dab4b84a755a49f187e93e684e85659af0e2a49
---
 gnu/packages/maths.scm | 14 ++++++--------
 1 file changed, 6 insertions(+), 8 deletions(-)


base-commit: d4869b7e43d823bccc8f6d81dd9f5d2c13cb8f25

Comments

Andreas Enge Sept. 13, 2024, 9:18 a.m. UTC | #1
Hello Efraim,

Am Thu, Sep 12, 2024 at 06:29:38PM +0300 schrieb Efraim Flashner:
> * gnu/packages/maths.scm (sleef): Update to 3.6.1.
> [arguments]: Set build-type to release.  Update configure-flags to only
> set building a shared library.
> [inputs]: Remove openssl-1.1.  Add mpfr, openssl.

the changes look good to me (but I did not try to build the package,
assuming you have alredy done so).

Why build only a shared library?

Andreas
Eric Bavier Sept. 13, 2024, 2:11 p.m. UTC | #2
Hi Efraim,

Also looks good to me. I tested with build of llama-cpp for x86_64. Some other Python users currently FTBFS for other reasons it seems.

This version of Sleef even comes with RISC-V Vector extension support :-) .

`~Eric

On September 12, 2024 3:29:38 PM UTC, Efraim Flashner <efraim@flashner.co.il> wrote:
>* gnu/packages/maths.scm (sleef): Update to 3.6.1.
>[arguments]: Set build-type to release.  Update configure-flags to only
>set building a shared library.
>[inputs]: Remove openssl-1.1.  Add mpfr, openssl.
>
>Change-Id: I3dab4b84a755a49f187e93e684e85659af0e2a49
>---
> gnu/packages/maths.scm | 14 ++++++--------
> 1 file changed, 6 insertions(+), 8 deletions(-)
>
>diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
>index a0cc0788caf..9a08e78d56b 100644
>--- a/gnu/packages/maths.scm
>+++ b/gnu/packages/maths.scm
>@@ -8,7 +8,7 @@
> ;;; Copyright © 2015–2024 Ricardo Wurmus <rekado@elephly.net>
> ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
> ;;; Copyright © 2015, 2018 Mark H Weaver <mhw@netris.org>
>-;;; Copyright © 2015-2023 Efraim Flashner <efraim@flashner.co.il>
>+;;; Copyright © 2015-2024 Efraim Flashner <efraim@flashner.co.il>
> ;;; Copyright © 2015 Fabian Harfert <fhmgufs@web.de>
> ;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
> ;;; Copyright © 2016, 2018, 2020, 2021 Kei Kebreau <kkebreau@posteo.net>
>@@ -812,7 +812,7 @@ (define-public gsl
> (define-public sleef
>   (package
>     (name "sleef")
>-    (version "3.5.1")
>+    (version "3.6.1")
>     (source
>      (origin
>        (method git-fetch)
>@@ -821,17 +821,15 @@ (define-public sleef
>              (commit version)))
>        (file-name (git-file-name name version))
>        (sha256
>-        (base32 "1jybqrl2dvjxzg30xrhh847s375n2jr1pix644wi6hb5wh5mx3f7"))))
>+        (base32 "14y1zf621zp0333vs29pc7pcc31gsrrs3q49b6qmd1kz6c7a7fp2"))))
>     (build-system cmake-build-system)
>     (arguments
>      (list
>+      #:build-type "Release"
>       #:configure-flags
>-      #~(list "-DCMAKE_BUILD_TYPE=Release"
>-              (string-append "-DCMAKE_INSTALL_LIBDIR=" #$output "/lib")
>-              (string-append "-DCMAKE_INSTALL_PREFIX=" #$output))))
>-    ;; XXX: Removed mpfr because of https://github.com/shibatch/sleef/issues/458
>+      #~(list "-DSLEEF_BUILD_SHARED_LIBS=ON")))
>     (inputs
>-     (list fftw gmp openssl-1.1))
>+     (list fftw gmp mpfr openssl))
>     (home-page "https://sleef.org/")
>     (synopsis "SIMD library for evaluating elementary functions and DFT")
>     (description
>
>base-commit: d4869b7e43d823bccc8f6d81dd9f5d2c13cb8f25
>-- 
>Efraim Flashner   <efraim@flashner.co.il>   רנשלפ םירפא
>GPG key = A28B F40C 3E55 1372 662D  14F7 41AA E7DC CA3D 8351
>Confidentiality cannot be guaranteed on emails sent or received unencrypted
>
>
>
Efraim Flashner Sept. 15, 2024, 12:47 p.m. UTC | #3
On Fri, Sep 13, 2024 at 11:18:45AM +0200, Andreas Enge wrote:
> Hello Efraim,
> 
> Am Thu, Sep 12, 2024 at 06:29:38PM +0300 schrieb Efraim Flashner:
> > * gnu/packages/maths.scm (sleef): Update to 3.6.1.
> > [arguments]: Set build-type to release.  Update configure-flags to only
> > set building a shared library.
> > [inputs]: Remove openssl-1.1.  Add mpfr, openssl.
> 
> the changes look good to me (but I did not try to build the package,
> assuming you have alredy done so).
> 
> Why build only a shared library?

The current version only provides a shared library but the new version
defaults to a static library. This changes it back to what we have now.
Efraim Flashner Sept. 15, 2024, 12:48 p.m. UTC | #4
On Fri, Sep 13, 2024 at 02:11:09PM +0000, Eric Bavier wrote:
> Hi Efraim,
> 
> Also looks good to me. I tested with build of llama-cpp for x86_64. Some other Python users currently FTBFS for other reasons it seems.
> 
> This version of Sleef even comes with RISC-V Vector extension support :-) .
> 
> `~Eric

I think for the vector support on RISC-V we need to build with gcc-14 or
llvm-17+.

At first build this fixes build failures on aarch64 and riscv64, but
breaks support for i686 and one of the other architectures. I was hoping
to get feedback from the QA system to see if it built there and just not
on my hardware.
Andreas Enge Sept. 16, 2024, 9:35 a.m. UTC | #5
Am Sun, Sep 15, 2024 at 03:47:56PM +0300 schrieb Efraim Flashner:
> > Why build only a shared library?
> The current version only provides a shared library but the new version
> defaults to a static library. This changes it back to what we have now.

Okay, fine then! I wonder whether it makes sense to build both
(which seems to be the Autotools default), but I think static libraries
are rarely useful actually, and since we did not build one before and
noone complained, we can leave it to a shared library.

Andreas
Efraim Flashner Sept. 17, 2024, 6:25 p.m. UTC | #6
Patch applied
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a0cc0788caf..9a08e78d56b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -8,7 +8,7 @@ 
 ;;; Copyright © 2015–2024 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
 ;;; Copyright © 2015, 2018 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015-2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015-2024 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2015 Fabian Harfert <fhmgufs@web.de>
 ;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2016, 2018, 2020, 2021 Kei Kebreau <kkebreau@posteo.net>
@@ -812,7 +812,7 @@  (define-public gsl
 (define-public sleef
   (package
     (name "sleef")
-    (version "3.5.1")
+    (version "3.6.1")
     (source
      (origin
        (method git-fetch)
@@ -821,17 +821,15 @@  (define-public sleef
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1jybqrl2dvjxzg30xrhh847s375n2jr1pix644wi6hb5wh5mx3f7"))))
+        (base32 "14y1zf621zp0333vs29pc7pcc31gsrrs3q49b6qmd1kz6c7a7fp2"))))
     (build-system cmake-build-system)
     (arguments
      (list
+      #:build-type "Release"
       #:configure-flags
-      #~(list "-DCMAKE_BUILD_TYPE=Release"
-              (string-append "-DCMAKE_INSTALL_LIBDIR=" #$output "/lib")
-              (string-append "-DCMAKE_INSTALL_PREFIX=" #$output))))
-    ;; XXX: Removed mpfr because of https://github.com/shibatch/sleef/issues/458
+      #~(list "-DSLEEF_BUILD_SHARED_LIBS=ON")))
     (inputs
-     (list fftw gmp openssl-1.1))
+     (list fftw gmp mpfr openssl))
     (home-page "https://sleef.org/")
     (synopsis "SIMD library for evaluating elementary functions and DFT")
     (description