diff mbox series

[bug#72822,2/2] gnu: josm: Update to 19160.

Message ID 14590dc93e101bd37cd6d5f8ad7cefb32bdb3374.1724696223.git.julien@lepiller.eu
State New
Headers show
Series [bug#72822,1/2] gnu: java-jmapviewer: Update to 2.20. | expand

Commit Message

Julien Lepiller Aug. 26, 2024, 6:18 p.m. UTC
* gnu/packages/geo.scm (josm): Update to 19160.
[arguments]: Update phases accordingly.  Update launcher following josm
advice.

Change-Id: Ic168cb04cf4248167b0724faecba8f2b2d238527
---
 gnu/packages/geo.scm | 10 ++++++++--
 1 file changed, 8 insertions(+), 2 deletions(-)

Comments

Andreas Enge Sept. 13, 2024, 10:42 a.m. UTC | #1
Hello Julien,

the patches look good to me. Given the delay in QA, I think you can push them.

Andreas
Julien Lepiller Sept. 14, 2024, 4:53 p.m. UTC | #2
Le Fri, 13 Sep 2024 12:42:54 +0200,
Andreas Enge <andreas@enge.fr> a écrit :

> Hello Julien,
> 
> the patches look good to me. Given the delay in QA, I think you can
> push them.
> 
> Andreas
> 

Pushed to master as 5fb9e04b6de24d5ff6478c9e4abe88a3a21fc43a and
e48426b45421eb8199a0dadbcd0eef3f14511e27, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 70dc127c1d..171821fe4d 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2200,7 +2200,7 @@  (define-public java-opening-hours-parser
 (define-public josm
   (package
     (name "josm")
-    (version "18907")
+    (version "19160")
     (source (origin
               (method svn-fetch)
               (uri (svn-reference
@@ -2209,7 +2209,7 @@  (define-public josm
                      (recursive? #f)))
               (sha256
                (base32
-                "0vkczijw537f4y1b7hfxa45k3ww6nf2cf485b19dnbgh9ab6mnjl"))
+                "06m6rg9czs7mhkh0byd3c8n8y1gbzqqw2iy7qyn4084al4mdrw2z"))
               (file-name (string-append name "-" version "-checkout"))
               (modules '((guix build utils)))
             (snippet
@@ -2280,6 +2280,9 @@  (define-public josm
            (lambda _
              (system* "javac" "scripts/BuildProjectionDefinitions.java"
                       "-cp" "build/classes")
+             (mkdir-p "resources/data/projection")
+             (with-output-to-file "resources/data/projection/custom-epsg"
+               (lambda _ (display "")))
              (mkdir-p "data/projection")
              (with-output-to-file "data/projection/custom-epsg"
                (lambda _ (display "")))
@@ -2342,6 +2345,9 @@  (define-public josm
                                                (not (string-contains jar "-javacc-"))))
                                         (string-split (getenv "CLASSPATH") #\:))
                                       ":")
+                                    " --add-exports=java.base/sun.security.action=ALL-UNNAMED"
+                                    " --add-exports=java.desktop/com.sun.imageio.plugins.jpeg=ALL-UNNAMED"
+                                    " --add-exports=java.desktop/com.sun.imageio.spi=ALL-UNNAMED"
                                     " org.openstreetmap.josm.gui.MainApplication"))))
                (chmod (string-append bin "/josm") #o755))
              #t)))))