diff mbox series

[bug#73176] gnu: go-1.20: Build with gccgo-12 on some systems.

Message ID 3b84788fb81704ab8ee1d325f51e0570c00cc6a1.1726047022.git.efraim@flashner.co.il
State New
Headers show
Series [bug#73176] gnu: go-1.20: Build with gccgo-12 on some systems. | expand

Commit Message

Efraim Flashner Sept. 11, 2024, 10:04 a.m. UTC
* gnu/packages/golang.scm (go-1.20)[native-inputs]: Don't replace the
gccgo input on architectures bootstrapping go with it.

Change-Id: I26831b2bcfe623f6eb0ac7c16b463e5e873110e6
---

This should only cause rebuilds on riscv64 and ppc64le.

 gnu/packages/golang.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)


base-commit: b6d5a7f5836739dab884b49a64ca354794dd845f

Comments

Sharlatan Hellseher Sept. 12, 2024, 2:32 p.m. UTC | #1
Hi,

Pushed as d893d040478f07fbfb08e0ff18549ab4215dcca2 to go-team.

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9f04b8e4232..95aca837ffc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1,5 +1,5 @@ 
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016-2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016-2024 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
 ;;; Copyright © 2016 Andy Wingo <wingo@igalia.com>
 ;;; Copyright © 2016, 2019, 2021 Ludovic Courtès <ludo@gnu.org>
@@ -811,7 +811,10 @@  (define-public go-1.20
      ;; See 'src/cmd/dist/notgo117.go' in the source code distribution,
      ;; as well as the upstream discussion of this topic:
      ;; https://go.dev/issue/44505
-     (alist-replace "go" (list go-1.17) (package-native-inputs go-1.17)))))
+     ;; We continue to use gccgo-12 since it provides go-1.18.
+     (if (member (%current-system) (package-supported-systems go-1.4))
+         (alist-replace "go" (list go-1.17) (package-native-inputs go-1.17))
+         (package-native-inputs go-1.17)))))
 
 (define-public go-1.21
   (package