diff mbox series

[bug#73073,v2,2/8] gnu: gnome-recipes: Move libgd origin from phases to native-inputs.

Message ID 718328743b18d6a8b5f60bf40c8bdc14cf5ad1bc.1725930587.git.zimon.toutoune@gmail.com
State New
Headers show
Series Allow origin inside inputs with "new style". | expand

Commit Message

Simon Tournier Sept. 10, 2024, 1:27 a.m. UTC
* gnu/packages/dlang.scm (gnome-recipes)[arguments]<phases>: Move libgd
origin from here...
[native-inputs]: ...to here.

Change-Id: Ic1775a66608e114b5b31058386c8b739c155b7a5
---
 gnu/packages/gnome.scm | 19 ++++++++++---------
 1 file changed, 10 insertions(+), 9 deletions(-)

Comments

Liliana Marie Prikler Sept. 10, 2024, 4:30 a.m. UTC | #1
Am Dienstag, dem 10.09.2024 um 03:27 +0200 schrieb Simon Tournier:
> * gnu/packages/dlang.scm (gnome-recipes)[arguments]<phases>: Move
> libgd
> origin from here...
> [native-inputs]: ...to here.
> 
> Change-Id: Ic1775a66608e114b5b31058386c8b739c155b7a5
> ---
>  gnu/packages/gnome.scm | 19 ++++++++++---------
>  1 file changed, 10 insertions(+), 9 deletions(-)
> 
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index 7339000436..d80d8cf33f 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -799,15 +799,7 @@ (define-public gnome-recipes
>            (add-after 'unpack 'unpack-libgd
>              (lambda _
>                (copy-recursively
> -               #$(origin
> -                   (method git-fetch)
> -                   (uri (git-reference
> -                         (url
> "https://gitlab.gnome.org/GNOME/libgd")
> -                         (commit
> "c7c7ff4e05d3fe82854219091cf116cce6b19de0")))
> -                   (file-name (git-file-name "libgd" version))
> -                   (sha256
> -                    (base32
> -                    
> "16yld0ap7qj1n96h4f2sqkjmibg7xx5xwkqxdfzam2nmyfdlrrrs")))
> +               #$(this-package-native-input (git-file-name "libgd"
> version))
>                 "subprojects/libgd"))))))
>      (inputs (list glib
>                    gnome-autoar
> @@ -821,6 +813,15 @@ (define-public gnome-recipes
>      (native-inputs (list desktop-file-utils ;for update-desktop-
> database
>                           gettext-minimal
>                           `(,glib "bin")
> +                         (origin
> +                           (method git-fetch)
> +                           (uri (git-reference
> +                                 (url
> "https://gitlab.gnome.org/GNOME/libgd")
> +                                 (commit
> "c7c7ff4e05d3fe82854219091cf116cce6b19de0")))
> +                           (file-name (git-file-name "libgd"
> version))
"libgd-checkout" would be both more honest and easier to get right.


Cheers
Simon Tournier Sept. 10, 2024, 7:58 a.m. UTC | #2
Hi Liliana,

On Tue, 10 Sep 2024 at 06:30, Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:

>> +               #$(this-package-native-input (git-file-name "libgd" version))

[...]

>> +                         (origin
>> +                           (method git-fetch)
>> +                           (uri (git-reference
>> +                                 (url "https://gitlab.gnome.org/GNOME/libgd")
>> +                                 (commit "c7c7ff4e05d3fe82854219091cf116cce6b19de0")))
>> +                           (file-name (git-file-name "libgd" version))
>
> "libgd-checkout" would be both more honest and easier to get right.

Thanks for the feedback.

Cheers,
simon
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7339000436..d80d8cf33f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -799,15 +799,7 @@  (define-public gnome-recipes
           (add-after 'unpack 'unpack-libgd
             (lambda _
               (copy-recursively
-               #$(origin
-                   (method git-fetch)
-                   (uri (git-reference
-                         (url "https://gitlab.gnome.org/GNOME/libgd")
-                         (commit "c7c7ff4e05d3fe82854219091cf116cce6b19de0")))
-                   (file-name (git-file-name "libgd" version))
-                   (sha256
-                    (base32
-                     "16yld0ap7qj1n96h4f2sqkjmibg7xx5xwkqxdfzam2nmyfdlrrrs")))
+               #$(this-package-native-input (git-file-name "libgd" version))
                "subprojects/libgd"))))))
     (inputs (list glib
                   gnome-autoar
@@ -821,6 +813,15 @@  (define-public gnome-recipes
     (native-inputs (list desktop-file-utils ;for update-desktop-database
                          gettext-minimal
                          `(,glib "bin")
+                         (origin
+                           (method git-fetch)
+                           (uri (git-reference
+                                 (url "https://gitlab.gnome.org/GNOME/libgd")
+                                 (commit "c7c7ff4e05d3fe82854219091cf116cce6b19de0")))
+                           (file-name (git-file-name "libgd" version))
+                           (sha256
+                            (base32
+                             "16yld0ap7qj1n96h4f2sqkjmibg7xx5xwkqxdfzam2nmyfdlrrrs")))
                          itstool
                          pkg-config
                          python))