diff mbox series

[bug#73055] doc: Explain `git format-patch` revision format

Message ID 7098b72d119941801db2c9f38a8a4f2dde03b540.1725562109.git.ekaitz@elenq.tech
State New
Headers show
Series [bug#73055] doc: Explain `git format-patch` revision format | expand

Commit Message

Ekaitz Zarraga Sept. 5, 2024, 6:48 p.m. UTC
* doc/contributing.texi(Sending a Patch Series): Add a note about
`git format-patch` revision format and link to git documentation.

Change-Id: Ie08f85dc19e3804165fb184664b74e85a804d7c4
---
 doc/contributing.texi | 12 ++++++++++++
 1 file changed, 12 insertions(+)


base-commit: 7d2ced8d6d9c38327592d312376d59a8c37fc160

Comments

Maxim Cournoyer Sept. 8, 2024, 1:31 p.m. UTC | #1
Hi Ekaitz,

Ekaitz Zarraga <ekaitz@elenq.tech> writes:

> * doc/contributing.texi(Sending a Patch Series): Add a note about
> `git format-patch` revision format and link to git documentation.
>
> Change-Id: Ie08f85dc19e3804165fb184664b74e85a804d7c4
> ---
>  doc/contributing.texi | 12 ++++++++++++
>  1 file changed, 12 insertions(+)
>
> diff --git a/doc/contributing.texi b/doc/contributing.texi
> index 73f7addbef..d5d63ebdbd 100644
> --- a/doc/contributing.texi
> +++ b/doc/contributing.texi
> @@ -2187,6 +2187,18 @@ Sending a Patch Series
>        --cover-letter --base=auto
>  @end example
>  
> +@quotation Note
> +@code{git format-patch} accepts a wide range of
> +@uref{https://git-scm.com/docs/gitrevisions, revision range} specifiers.
> +For example, if you are working in a branch, you could select all commits
> +in your branch starting at @code{master}.
> +
> +@example
> +$ git format-patch master..@var{MY_BRANCH} -o outgoing \
> +      --cover-letter --base=auto

The --base=auto can be dropped since it's part of our default git
config, which is automatically installed for all of our contributors
(c.f.: etc/git/gitconfig) when they build the Guix source.

Otherwise, LGTM, if others think it has enough value to be added.

--
Thanks,
Maxim
Ekaitz Zarraga Sept. 8, 2024, 8:16 p.m. UTC | #2
> The --base=auto can be dropped since it's part of our default git
> config, which is automatically installed for all of our contributors
> (c.f.: etc/git/gitconfig) when they build the Guix source.
> 
> Otherwise, LGTM, if others think it has enough value to be added.
> 
> --
> Thanks,
> Maxim

Hi!

Should we remove the --base=auto from all the examples or only mine?

Thanks!
Maxim Cournoyer Sept. 9, 2024, 2:53 a.m. UTC | #3
Hi Ekaitz,

Ekaitz Zarraga <ekaitz@elenq.tech> writes:

>> The --base=auto can be dropped since it's part of our default git
>> config, which is automatically installed for all of our contributors
>> (c.f.: etc/git/gitconfig) when they build the Guix source.
>> Otherwise, LGTM, if others think it has enough value to be added.
>> --
>> Thanks,
>> Maxim
>
> Hi!
>
> Should we remove the --base=auto from all the examples or only mine?

Your commit shouldn't add it, and as an extra, if you don't mind the
extra scope, another commit removing it from all the existing examples
would be nice.
diff mbox series

Patch

diff --git a/doc/contributing.texi b/doc/contributing.texi
index 73f7addbef..d5d63ebdbd 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -2187,6 +2187,18 @@  Sending a Patch Series
       --cover-letter --base=auto
 @end example
 
+@quotation Note
+@code{git format-patch} accepts a wide range of
+@uref{https://git-scm.com/docs/gitrevisions, revision range} specifiers.
+For example, if you are working in a branch, you could select all commits
+in your branch starting at @code{master}.
+
+@example
+$ git format-patch master..@var{MY_BRANCH} -o outgoing \
+      --cover-letter --base=auto
+@end example
+@end quotation
+
 We can now send @emph{just} the cover letter to the
 @email{guix-patches@@gnu.org} address, which will create an issue
 that we can send the rest of the patches to.