diff mbox series

[bug#73078] qutebrowser: Update to 3.2.1.

Message ID 20240906172304.5080-1-herman@rimm.ee
State New
Headers show
Series [bug#73078] qutebrowser: Update to 3.2.1. | expand

Commit Message

Herman Rimm Sept. 6, 2024, 5:23 p.m. UTC
* gnu/packages/web-browser.scm (qutebrowser): Update to 3.2.1.
[source]: Use name instead of "qutebrowser" literal.
---
 gnu/packages/web-browsers.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

Comments

Rodion Goritskov Sept. 7, 2024, 4:04 p.m. UTC | #1
user guix
usertag 73078 + reviewed-looks-good
thanks

Guix QA review form submission:
It successfully starts and loads a couple of pages

Items marked as checked: Lint warnings, Package builds, Commit messages
Z572 Sept. 7, 2024, 4:09 p.m. UTC | #2
Herman Rimm via Guix-patches via <guix-patches@gnu.org> writes:

should "gnu: qutebrowser: Update to 3.2.1."

> * gnu/packages/web-browser.scm (qutebrowser): Update to 3.2.1.
> [source]: Use name instead of "qutebrowser" literal.
> ---
>  gnu/packages/web-browsers.scm | 11 ++++++-----
>  1 file changed, 6 insertions(+), 5 deletions(-)
>
> diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
> index a8c51b503b..70a58132bb 100644
> --- a/gnu/packages/web-browsers.scm
> +++ b/gnu/packages/web-browsers.scm
> @@ -464,15 +464,16 @@ (define-public kristall
>  (define-public qutebrowser
>    (package
>      (name "qutebrowser")
> -    (version "3.1.0")
> +    (version "3.2.1")
>      (source
>       (origin
>         (method url-fetch)
> -       (uri (string-append "https://github.com/qutebrowser/"
> -                           "qutebrowser/releases/download/v" version "/"
> -                           "qutebrowser-" version ".tar.gz"))
> +       (uri (string-append "https://github.com/" name "/" name
> +                           "/releases/download/v" version "/" name "-"
> +                           version ".tar.gz"))

Normally we shouldn't do this, if one day we rename this package
qutebrowser-minimal the link will be wrong.
And I switched to git-fetch, because this is a better option, you can
specify the branch/commit, including downloading the source code is a
directory, you can directly cd into the file.

>         (sha256
> -        (base32 "0prf9c7nx4aizfczjb0fpsn3alz210i6wc7s2jwb1mh8r8fcq3ah"))))
> +         (base32
> +           "0zc9736zpmzn7250wbgk6n1q7nc05i0vic15na3qvcsxdhmaz9q2"))))
>      (build-system python-build-system)
>      (native-inputs
>       (list python-attrs))               ; for tests

add asciidoc for fix build
diff mbox series

Patch

diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index a8c51b503b..70a58132bb 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -464,15 +464,16 @@  (define-public kristall
 (define-public qutebrowser
   (package
     (name "qutebrowser")
-    (version "3.1.0")
+    (version "3.2.1")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "https://github.com/qutebrowser/"
-                           "qutebrowser/releases/download/v" version "/"
-                           "qutebrowser-" version ".tar.gz"))
+       (uri (string-append "https://github.com/" name "/" name
+                           "/releases/download/v" version "/" name "-"
+                           version ".tar.gz"))
        (sha256
-        (base32 "0prf9c7nx4aizfczjb0fpsn3alz210i6wc7s2jwb1mh8r8fcq3ah"))))
+         (base32
+           "0zc9736zpmzn7250wbgk6n1q7nc05i0vic15na3qvcsxdhmaz9q2"))))
     (build-system python-build-system)
     (native-inputs
      (list python-attrs))               ; for tests