diff mbox series

[bug#72355,2/2] gnu: Add python-klaus.

Message ID ded817172d5273e1d43be77808374c0cd4b7d35a.1722275874.git.jgart@dismail.de
State New
Headers show
Series [bug#72355,1/2] gnu: Add python-httpauth. | expand

Commit Message

jgart July 29, 2024, 6:28 p.m. UTC
* gnu/packages/version-control.scm (python-klaus): New variable.

Change-Id: I1b7c31deb799e0ea5195eda109740fdb90e5fabd
---
 gnu/packages/version-control.scm | 47 +++++++++++++++++++++++++++++++-
 1 file changed, 46 insertions(+), 1 deletion(-)

Comments

jgart Aug. 21, 2024, 12:39 a.m. UTC | #1
merge ahoy!
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index cf7f7b0ad8..d8692ef803 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -41,7 +41,7 @@ 
 ;;; Copyright © 2021 François J. <francois-oss@avalenn.eu>
 ;;; Copyright © 2021 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
-;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021, 2024 jgart <jgart@dismail.de>
 ;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
 ;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
@@ -716,6 +716,51 @@  (define-public git-minimal/pinned
                (base32
                 "0bqz401dyp8wnjj3k5ahrniwk4dalndysqazzwdvv25hqbkacm70"))))))
 
+(define-public python-klaus
+  (package
+    (name "python-klaus")
+    (version "3.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "klaus" version))
+              (sha256
+               (base32
+                "1w6sl15llnkcg7kmnpn64awdiis061q2gijnhdx0ng7z4p1glapl"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:tests? #f ; TODO: https://github.com/jonashaag/klaus/issues/322
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'configure-git
+            (lambda* (#:key inputs #:allow-other-keys)
+              (for-each (lambda (file)
+                          (substitute* file
+                            (("\"git\"")
+                             (string-append "\"" (search-input-file inputs "/bin/git") "\""))))
+                        (list "klaus/ctagsutils.py"
+                              "klaus/repo.py"
+                              "klaus/utils.py"
+                              "tests/test_contrib.py"
+                              "tests/test_make_app.py")))))))
+    (inputs (list git-minimal))
+    (native-inputs
+     (list python-pytest))
+    (propagated-inputs
+     (list python-dulwich python-flask python-httpauth
+           python-humanize python-pygments python-werkzeug))
+    (home-page "https://github.com/jonashaag/klaus")
+    (synopsis "Simple git web viewer")
+    (description "klaus is a simple, easy-to-set-up git web viewer. It features
+@itemize
+@item Super easy to set up -- no configuration required
+@item Syntax highlighting
+@item Markdown + RestructuredText rendering support
+@item Pull + push support (Git Smart HTTP)
+@item Code navigation using Exuberant ctags
+@end itemize")
+    (license license:isc)))
+
 (define-public git2cl
   (let ((commit "1d74d4c0d933fc69ed5cec838c73502584dead05"))
     (package