diff mbox series

[bug#72318,v2] gnu: Add fyi.

Message ID 76bc139042603c6a91d2e46ef834cea1a9d07c3a.1722635856.git.ashish.is@lostca.se
State New
Headers show
Series [bug#72318,v2] gnu: Add fyi. | expand

Commit Message

Ashish SHUKLA Aug. 2, 2024, 10:01 p.m. UTC
* gnu/packages/xdisorg.scm (fyi): New variable.

Change-Id: I8bbc45324495cc0248bedd793b1a951aa0126706
---
 gnu/packages/xdisorg.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: b20956651a53a8f23828fdeb6945e1a31e6997a8

Comments

Nicolas Goaziou Aug. 19, 2024, 6:07 p.m. UTC | #1
Hello,

Ashish SHUKLA via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/xdisorg.scm (fyi): New variable.

Thank you. Applied with the following changes.

> +(define-public fyi
> +  (package
> +    (name "fyi")
> +    (version "1.0.2")

I updated it to 1.0.3.

> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://codeberg.org/dnkl/fyi")
> +                    (commit version)))
> +              (file-name (git-file-name name version))
> +              (sha256 (base32 "29l1w30wsm3gac0s1f81jxgmibi3qgx8f73hi047ykbxiwdccvqz"))))

I updated this accordingly, but this hash was also wrong for the version
1.0.2, FWIW.

> +    (synopsis "A lightweight alternative to notify-send")

I removed the article "A" at the beginning of the synopsis.

> +    (description "FYI (for your information) is a command line utility to send

I used @acronym{...} Texinfo command here.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 4c12835b24..67cd491f66 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -63,6 +63,7 @@ 
 ;;; Copyright © 2022 Mehmet Tekman <mtekman89@gmail.com>
 ;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;; Copyright © 2024 Igor Goryachev <igor@goryachev.org>
+;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3852,3 +3853,24 @@  (define-public xxkb
 accepts events from XKB.  That means that it will work with the existing
 setup of your X Server without any modifications.")
     (license license:artistic2.0)))
+
+(define-public fyi
+  (package
+    (name "fyi")
+    (version "1.0.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://codeberg.org/dnkl/fyi")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256 (base32 "29l1w30wsm3gac0s1f81jxgmibi3qgx8f73hi047ykbxiwdccvqz"))))
+    (build-system meson-build-system)
+    (inputs (list dbus))
+    (native-inputs (list pkg-config))
+    (home-page "https://codeberg.org/dnkl/fyi")
+    (synopsis "A lightweight alternative to notify-send")
+    (description "FYI (for your information) is a command line utility to send
+desktop notifications to the user via a notification daemon implementing XDG desktop
+notifications.")
+    (license license:expat)))