@@ -63,6 +63,7 @@
;;; Copyright © 2022 Mehmet Tekman <mtekman89@gmail.com>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2024 Igor Goryachev <igor@goryachev.org>
+;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3852,3 +3853,24 @@ (define-public xxkb
accepts events from XKB. That means that it will work with the existing
setup of your X Server without any modifications.")
(license license:artistic2.0)))
+
+(define-public fyi
+ (package
+ (name "fyi")
+ (version "1.0.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/dnkl/fyi")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256 (base32 "29l1w30wsm3gac0s1f81jxgmibi3qgx8f73hi047ykbxiwdccvqz"))))
+ (build-system meson-build-system)
+ (inputs (list dbus))
+ (native-inputs (list pkg-config))
+ (home-page "https://codeberg.org/dnkl/fyi")
+ (synopsis "A lightweight alternative to notify-send")
+ (description "FYI (for your information) is a command line utility to send
+desktop notifications to the user via a notification daemon implementing XDG desktop
+notifications.")
+ (license license:expat)))