diff mbox series

[bug#72703] gnu: gtk+-2: Disable UI tests.

Message ID 318e036d5cb654ab4f9d570a4cd077ba3c5d15fd.1724015688.git.jonathan@terracrypt.net
State New
Headers show
Series [bug#72703] gnu: gtk+-2: Disable UI tests. | expand

Commit Message

Jonathan Frederickson Aug. 18, 2024, 9:14 p.m. UTC
* gnu/packages/gtk.scm (gtk+-2): Disable ui-tests. They seem to be flaky on
aarch64, and I haven't been able to get the package to build without this
change.

Change-Id: I5aa5a89a2874ad1c737cba16c3aaeedced606de3
---
 gnu/packages/gtk.scm | 3 +++
 1 file changed, 3 insertions(+)


base-commit: b20956651a53a8f23828fdeb6945e1a31e6997a8

Comments

Liliana Marie Prikler Aug. 18, 2024, 9:38 p.m. UTC | #1
Am Sonntag, dem 18.08.2024 um 17:14 -0400 schrieb Jonathan
Frederickson:
> * gnu/packages/gtk.scm (gtk+-2): Disable ui-tests. They seem to be
> flaky on aarch64, and I haven't been able to get the package to build
> without this change.
> 
> Change-Id: I5aa5a89a2874ad1c737cba16c3aaeedced606de3
> ---
Given that gtk+-2 is fairly lowlevel package, you might want to wrap
this snippet so that only applies to arches where it's known to be
flaky.

Cheers
Jonathan Frederickson Aug. 18, 2024, 10:57 p.m. UTC | #2
On Sun, Aug 18, 2024, at 5:38 PM, Liliana Marie Prikler wrote:
> Given that gtk+-2 is fairly lowlevel package, you might want to wrap
> this snippet so that only applies to arches where it's known to be
> flaky.

Ah, good point - I'll try and work out how to do this, and send an updated patch soon.
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 04183fa806..a0da976fab 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -980,6 +980,9 @@  (define-public gtk+-2
                 (("g_test_add_func \\(\"/recent-manager.*;") ""))
               (substitute* "gtk/tests/defaultvalue.c"
                 (("return g_test_run\\(\\);") ""))
+              ;; UI tests seem to be flaky on aarch64
+              (substitute* "gtk/tests/testing.c"
+                (("g_test_add_func \\(\"/ui-tests.*;") ""))
               ;; These require XPM support in Gdk-Pixbuf which is obsolete.
               (substitute* "gtk/tests/textbuffer.c"
                 (("g_test_add_func.*test_fill_empty\\);")