diff mbox series

[bug#72396,1/2] gnu: Add zycore.

Message ID 254535bd95290fdd6aca4bb5eb1b2e17330a91e3.1722420324.git.mcsinyx@disroot.org
State New
Headers show
Series gnu: Add zydis. | expand

Commit Message

ashish.is--- via Guix-patches" via July 31, 2024, 10:14 a.m. UTC
* gnu/packages/engineering.scm (zycore): New variable.

Change-Id: Ia38413f43bc667a9a12916d3f0e786e06f6d358f
---
 gnu/packages/engineering.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Nicolas Graves Aug. 15, 2024, 2:19 p.m. UTC | #1
On 2024-07-31 19:14, guix-patches--- via wrote:

> * gnu/packages/engineering.scm (zycore): New variable.
>
> +    (synopsis "Internal library for Zydis.")

Hi Nguyễn Gia Phong,

A minor nitpick:
zycore@1.5.0: no period allowed at the end of the synopsis

Checking `guix lint` would have told you ;)

Otherwise LGTM, built and rebuilt deterministically.
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index f411d4ac1ed6..b6ae19101b42 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -40,6 +40,7 @@ 
 ;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2023 pinoaffe <pinoaffe@gmail.com>
 ;;; Copyright © 2024 Juliana Sims <juli@incana.org>
+;;; Copyright © 2024 Nguyễn Gia Phong <mcsinyx@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1926,6 +1927,29 @@  (define-public radare2
 it suitable for security research and analysis.")
     (license license:lgpl3)))
 
+(define-public zycore
+  (package
+    (name "zycore")
+    (version "1.5.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/zyantific/zycore-c")
+                    (commit (string-append "v" version))))
+              (sha256
+               (base32 "0s962pkqybh1xbs75y4jb4bqc9qnq0sviqd570mirqdhhq87agib"))
+              (file-name (git-file-name name version))))
+    (build-system cmake-build-system)
+    (native-inputs (list googletest))
+    (arguments `(#:configure-flags '("-DZYCORE_BUILD_SHARED_LIBS=ON"
+                                     "-DZYCORE_BUILD_TESTS=ON")))
+    (home-page "https://github.com/zyantific/zycore-c")
+    (synopsis "Internal library for Zydis.")
+    (description
+     "This package provides platfrom-independent types, macros
+and a fallback for environments without libc for Zydis.")
+    (license license:expat)))
+
 (define-public asco
   (package
     (name "asco")