diff mbox series

[bug#72330] gnu: xpra: Update to 6.1.0

Message ID 7fb3e4467339bb60ccf54eb1ad9ae90afb1fc725.1722141217.git.atai@atai.org
State New
Headers show
Series [bug#72330] gnu: xpra: Update to 6.1.0 | expand

Commit Message

Andy Tai July 28, 2024, 4:34 a.m. UTC
* gnu/packages/xorg.scm (xpra): Update to 6.1.0.
* gnu/packages/patches/xpra-6.0-install_libs.patch: Update for xpra 6.1.0.

Change-Id: I38dab99fbb369ab7e8daf2795dc37aa1a36a63de
---
 gnu/packages/patches/xpra-6.0-install_libs.patch | 10 +++++-----
 gnu/packages/xorg.scm                            |  4 ++--
 2 files changed, 7 insertions(+), 7 deletions(-)


base-commit: 46a64c7fdd057283063aae6df058579bb07c4b6a

Comments

Andy Tai July 28, 2024, 11:23 p.m. UTC | #1
patch passed QA
https://qa.guix.gnu.org/issue/72330
Z572 July 30, 2024, 6:19 a.m. UTC | #2
Andy Tai <atai@atai.org> writes:

> * gnu/packages/xorg.scm (xpra): Update to 6.1.0.
> * gnu/packages/patches/xpra-6.0-install_libs.patch: Update for xpra 6.1.0.
                              ^^^ maybe rename this file to 6.1 ?.
>
> Change-Id: I38dab99fbb369ab7e8daf2795dc37aa1a36a63de
> ---
>  gnu/packages/patches/xpra-6.0-install_libs.patch | 10 +++++-----
>  gnu/packages/xorg.scm                            |  4 ++--
>  2 files changed, 7 insertions(+), 7 deletions(-)
>
> diff --git a/gnu/packages/patches/xpra-6.0-install_libs.patch b/gnu/packages/patches/xpra-6.0-install_libs.patch
> index c608b519f4..0ec2aee288 100644
> --- a/gnu/packages/patches/xpra-6.0-install_libs.patch
> +++ b/gnu/packages/patches/xpra-6.0-install_libs.patch
> @@ -4,19 +4,19 @@ This workaround for Gentoo interferes with our use of --no-compile during
>  the 'install stage.
>  
>  diff --git a/setup.py b/setup.py
> -index 4f066fa8bf..14a9ed65ed 100755
> +index be7a3758e8..28dc1be191 100755
>  --- a/setup.py
>  +++ b/setup.py
> -@@ -760,8 +760,6 @@ if modules_ENABLED:
> +@@ -953,8 +953,6 @@ if modules_ENABLED:
>   # Utility methods for building with Cython
>  
> - def do_add_cython_ext(*args, **kwargs):
> + def do_add_cython_ext(*args, **kwargs) -> None:
>  -    if "--no-compile" in sys.argv and not ("build" in sys.argv and "install" in sys.argv):
>  -        return
>       if not cython_ENABLED:
>           raise ValueError(f"cannot build {args}: cython compilation is disabled")
>       if cython_tracing_ENABLED:
> -@@ -1971,9 +1969,6 @@ else:
> +@@ -2175,9 +2173,6 @@ else:
>               if root_prefix.endswith("/usr"):
>                   # ie: "/" or "/usr/src/rpmbuild/BUILDROOT/xpra-0.18.0-0.20160513r12573.fc23.x86_64/"
>                   root_prefix = root_prefix[:-4]
> @@ -26,7 +26,7 @@ index 4f066fa8bf..14a9ed65ed 100755
>               print(f"  root_prefix={root_prefix!r}")
>               build_xpra_conf(root_prefix)
>  
> -@@ -2116,13 +2111,6 @@ else:
> +@@ -2320,13 +2315,6 @@ else:
>               if uinput_ENABLED:
>                   add_data_files("lib/udev/rules.d/", ["fs/lib/udev/rules.d/71-xpra-virtual-pointer.rules"])
>  
> diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
> index 6b953ef152..bdce6174ff 100644
> --- a/gnu/packages/xorg.scm
> +++ b/gnu/packages/xorg.scm
> @@ -6158,7 +6158,7 @@ (define-public xcompmgr
>  (define-public xpra
>    (package
>      (name "xpra")
> -    (version "6.0.2")
> +    (version "6.1.0")
>      (source
>       (origin
>         (method git-fetch)
> @@ -6167,7 +6167,7 @@ (define-public xpra
>             (commit (string-append "v" version))))
>         (file-name (git-file-name name version))
>         (sha256
> -        (base32 "176qxrksgr07jhrlny3zxybnvf091kxkfmfnv9ci3h2k1nbwqh2x"))
> +        (base32 "1x1ld2p3q47irqq6p1b3rd9ffbi7kvgxyvfmgi0skfin17b2aqx4"))
>         (patches (search-patches "xpra-6.0-systemd-run.patch"
>                                  "xpra-6.0-install_libs.patch"))))
>      (build-system python-build-system)
>
> base-commit: 46a64c7fdd057283063aae6df058579bb07c4b6a
Andy Tai Aug. 9, 2024, 1:15 a.m. UTC | #3
patch passes QA
https://qa.guix.gnu.org/issue/72330
diff mbox series

Patch

diff --git a/gnu/packages/patches/xpra-6.0-install_libs.patch b/gnu/packages/patches/xpra-6.0-install_libs.patch
index c608b519f4..0ec2aee288 100644
--- a/gnu/packages/patches/xpra-6.0-install_libs.patch
+++ b/gnu/packages/patches/xpra-6.0-install_libs.patch
@@ -4,19 +4,19 @@  This workaround for Gentoo interferes with our use of --no-compile during
 the 'install stage.
 
 diff --git a/setup.py b/setup.py
-index 4f066fa8bf..14a9ed65ed 100755
+index be7a3758e8..28dc1be191 100755
 --- a/setup.py
 +++ b/setup.py
-@@ -760,8 +760,6 @@ if modules_ENABLED:
+@@ -953,8 +953,6 @@ if modules_ENABLED:
  # Utility methods for building with Cython
 
- def do_add_cython_ext(*args, **kwargs):
+ def do_add_cython_ext(*args, **kwargs) -> None:
 -    if "--no-compile" in sys.argv and not ("build" in sys.argv and "install" in sys.argv):
 -        return
      if not cython_ENABLED:
          raise ValueError(f"cannot build {args}: cython compilation is disabled")
      if cython_tracing_ENABLED:
-@@ -1971,9 +1969,6 @@ else:
+@@ -2175,9 +2173,6 @@ else:
              if root_prefix.endswith("/usr"):
                  # ie: "/" or "/usr/src/rpmbuild/BUILDROOT/xpra-0.18.0-0.20160513r12573.fc23.x86_64/"
                  root_prefix = root_prefix[:-4]
@@ -26,7 +26,7 @@  index 4f066fa8bf..14a9ed65ed 100755
              print(f"  root_prefix={root_prefix!r}")
              build_xpra_conf(root_prefix)
 
-@@ -2116,13 +2111,6 @@ else:
+@@ -2320,13 +2315,6 @@ else:
              if uinput_ENABLED:
                  add_data_files("lib/udev/rules.d/", ["fs/lib/udev/rules.d/71-xpra-virtual-pointer.rules"])
 
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 6b953ef152..bdce6174ff 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6158,7 +6158,7 @@  (define-public xcompmgr
 (define-public xpra
   (package
     (name "xpra")
-    (version "6.0.2")
+    (version "6.1.0")
     (source
      (origin
        (method git-fetch)
@@ -6167,7 +6167,7 @@  (define-public xpra
            (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "176qxrksgr07jhrlny3zxybnvf091kxkfmfnv9ci3h2k1nbwqh2x"))
+        (base32 "1x1ld2p3q47irqq6p1b3rd9ffbi7kvgxyvfmgi0skfin17b2aqx4"))
        (patches (search-patches "xpra-6.0-systemd-run.patch"
                                 "xpra-6.0-install_libs.patch"))))
     (build-system python-build-system)