diff mbox series

[bug#71824] import: go: Fix indentation in help message.

Message ID 6525ad5e52ffe39ed078d76ae19d4bc9c7353562.1719591290.git.richard@freakingpenguin.com
State New
Headers show
Series [bug#71824] import: go: Fix indentation in help message. | expand

Commit Message

Richard Sent June 28, 2024, 4:14 p.m. UTC
* guix/scripts/import/go.scm (show-help) <recursive>: Indent second line.

Change-Id: Iad096231e26ed4e0e1c584f92e43f2695a2d8682
---
 guix/scripts/import/go.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


base-commit: 78b881722f08325c76096557313a0faee847c66f

Comments

jgart June 29, 2024, 1:08 a.m. UTC | #1
I'll let someone else comment on this since I'm not sure what our policy
is on indentation at the moment.

all best,

jgart
Sharlatan Hellseher July 1, 2024, 8:53 p.m. UTC | #2
Hi,

The change looks reasonable while comparing other importer' help:

--8<---------------cut here---------------start------------->8---
(guix/linux-gnu)[sharlatan@guxtil ~/code/guix]$: guix import cran --help
Usage: guix import cran PACKAGE-NAME
Import and convert the CRAN package for PACKAGE-NAME.

  -a, --archive=ARCHIVE  specify the archive repository
  -h, --help             display this help and exit
  -r, --recursive        import packages recursively
  -s, --style=STYLE      choose output style, either specification or variable
  -p, --license-prefix=PREFIX
                         add custom prefix to licenses
  -V, --version          display version information and exit

Report bugs to: bug-guix@gnu.org.
GNU Guix home page: <https://guix.gnu.org>
General help using Guix and GNU software: <https://guix.gnu.org/en/help/>
(guix/linux-gnu)[sharlatan@guxtil ~/code/guix]$: guix import pypi --help
Usage: guix import pypi PACKAGE-NAME
Import and convert the PyPI package for PACKAGE-NAME.

  -h, --help             display this help and exit
  -r, --recursive        import packages recursively
  -V, --version          display version information and exit

Report bugs to: bug-guix@gnu.org.
GNU Guix home page: <https://guix.gnu.org>
General help using Guix and GNU software: <https://guix.gnu.org/en/help/>
(guix/linux-gnu)[sharlatan@guxtil ~/code/guix]$: guix import go --help
Usage: guix import go PACKAGE-PATH[@VERSION]
Import and convert the Go module for PACKAGE-PATH.  Optionally, a version
can be specified after the arobas (@) character.

  -h, --help             display this help and exit
  -r, --recursive        generate package expressions for all Go modules
that are not yet in Guix
  -p, --goproxy=GOPROXY  specify which goproxy server to use
  --pin-versions         use the exact versions of a module's dependencies

Report bugs to: bug-guix@gnu.org.
GNU Guix home page: <https://guix.gnu.org>
--8<---------------cut here---------------end--------------->8---

--
Oleg
Sharlatan Hellseher July 1, 2024, 8:55 p.m. UTC | #3
And after applying patch locally:

--8<---------------cut here---------------start------------->8---
> ./pre-inst-env guix import go --help
Usage: guix import go PACKAGE-PATH[@VERSION]
Import and convert the Go module for PACKAGE-PATH.  Optionally, a version
can be specified after the arobas (@) character.

  -h, --help             display this help and exit
  -r, --recursive        generate package expressions for all Go modules
                         that are not yet in Guix
  -p, --goproxy=GOPROXY  specify which goproxy server to use
  --pin-versions         use the exact versions of a module's dependencies

Report bugs to: bug-guix@gnu.org.
GNU Guix home page: <https://www.gnu.org/software/guix/>
General help using Guix and GNU software: <https://guix.gnu.org/en/help/>
--8<---------------cut here---------------end--------------->8---
Sharlatan Hellseher July 1, 2024, 8:59 p.m. UTC | #4
Pushed as 69089674bb9fb2cc7b3285b73fb7dda7d99a2550 to master.

--
Oleg
diff mbox series

Patch

diff --git a/guix/scripts/import/go.scm b/guix/scripts/import/go.scm
index f1970d3543..b90c6ac72f 100644
--- a/guix/scripts/import/go.scm
+++ b/guix/scripts/import/go.scm
@@ -51,7 +51,7 @@  (define (show-help)
   -h, --help             display this help and exit"))
   (display (G_ "
   -r, --recursive        generate package expressions for all Go modules
-that are not yet in Guix"))
+                         that are not yet in Guix"))
   (display (G_ "
   -p, --goproxy=GOPROXY  specify which goproxy server to use"))
   (display (G_ "