diff mbox series

[bug#71640,5/6] gnu: python-websockets: Update to 12.0

Message ID c572057952bea3f3a63d692fd0c754407c60897b.1718763195.git.leo@famulari.name
State New
Headers show
Series [bug#71640,1/6] gnu: yt-dlp: Don't inherit from youtube-dl. | expand

Commit Message

Leo Famulari June 19, 2024, 2:13 a.m. UTC
* gnu/packages/python-web.scm (python-websockets): Update to 12.0.

Change-Id: I6217093bbdfb81b35eb7c8d59ada3f612b7d9511
---
 gnu/packages/python-web.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Maxim Cournoyer June 24, 2024, 2 a.m. UTC | #1
Hi,

Leo Famulari <leo@famulari.name> writes:

> * gnu/packages/python-web.scm (python-websockets): Update to 12.0.

That's a major version bump that causes the rebuild of 414 dependents.
We'll want to see what QA thinks (breakage?).
Leo Famulari June 27, 2024, 5:07 p.m. UTC | #2
On Sun, Jun 23, 2024 at 10:00:04PM -0400, Maxim Cournoyer wrote:
> Hi,
> 
> Leo Famulari <leo@famulari.name> writes:
> 
> > * gnu/packages/python-web.scm (python-websockets): Update to 12.0.
> 
> That's a major version bump that causes the rebuild of 414 dependents.
> We'll want to see what QA thinks (breakage?).

Right. According to QA, nothing is broken by this change:

https://qa.guix.gnu.org/issue/71640

Also, I checked if the 'streamlink' package still works, and it does.
That's an end-user application that uses python-websockets. Not sure if
my use of the program (streaming something from the web to VLC)
exercises websockets... but it does work.
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 98aa46dafc..eef63351ef 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6754,7 +6754,7 @@  (define-public python-warcio
 (define-public python-websockets
   (package
     (name "python-websockets")
-    (version "11.0.3")
+    (version "12.0")
     (source
      (origin
        (method git-fetch)
@@ -6764,7 +6764,7 @@  (define-public python-websockets
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "1hn1qzpk1fvhi5j5nz4xlvzwkj9y16c9gryrb4n4dza84qi1pna5"))))
+         "1a587a1knjsy9zmgab9v2yncx0803pg2hfcvf7kz6vs8ixaggqmh"))))
     (build-system python-build-system)
     (arguments
      (list #:phases