diff mbox series

[bug#71565] gnu: ibus-minimal: Graft to 1.5.29.

Message ID 3fce33491942c6e738a0975b56635ee8ed8fff2b.1718436440.git.liliana.prikler@gmail.com
State New
Headers show
Series [bug#71565] gnu: ibus-minimal: Graft to 1.5.29. | expand

Commit Message

Liliana Marie Prikler June 15, 2024, 7:18 a.m. UTC
This fixes an issue, where IBus was not able to query emoji lists.
See also <https://github.com/ibus/ibus/issues/2476>.

* gnu/packages/ibus.scm (ibus-minimal/fixed): New variable.
(ibus-minimal): Add ibus-minimal/fixed as replacement.
---
 gnu/packages/ibus.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)


base-commit: 7770e4140cddd5dc9c9879cb2bfcbd6cd4de59a0

Comments

Maxim Cournoyer June 17, 2024, 7:55 p.m. UTC | #1
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> This fixes an issue, where IBus was not able to query emoji lists.
> See also <https://github.com/ibus/ibus/issues/2476>.
>
> * gnu/packages/ibus.scm (ibus-minimal/fixed): New variable.
> (ibus-minimal): Add ibus-minimal/fixed as replacement.
> ---
>  gnu/packages/ibus.scm | 18 ++++++++++++++++++
>  1 file changed, 18 insertions(+)
>
> diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
> index c821279bd3..a2775b2f84 100644
> --- a/gnu/packages/ibus.scm
> +++ b/gnu/packages/ibus.scm
> @@ -81,6 +81,7 @@ (define-module (gnu packages ibus)
>  (define-public ibus-minimal
>    (package
>      (name "ibus")
> +    (replacement ibus-minimal/fixed)
>      (version "1.5.27")
>      (source (origin
>                (method url-fetch)
> @@ -279,6 +280,23 @@ (define-public ibus
>             (package-native-search-paths ibus-minimal)))
>      (properties (alist-delete 'hidden? (package-properties ibus-minimal)))))
>  
> +(define-public ibus-minimal/fixed

Is it useful to have the package 'public' at al here?  I think there are
considerations so that the package gets built by the CI, but I'm not
sure whether this applies to graft package (I guess it does).  Perhaps
we should document these gotchas, as I can never remember myself.
Liliana Marie Prikler June 17, 2024, 8:05 p.m. UTC | #2
Am Montag, dem 17.06.2024 um 15:55 -0400 schrieb Maxim Cournoyer:
> Hi Liliana,
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> 
> > This fixes an issue, where IBus was not able to query emoji lists.
> > See also <https://github.com/ibus/ibus/issues/2476>.
> > 
> > * gnu/packages/ibus.scm (ibus-minimal/fixed): New variable.
> > (ibus-minimal): Add ibus-minimal/fixed as replacement.
> > ---
> >  gnu/packages/ibus.scm | 18 ++++++++++++++++++
> >  1 file changed, 18 insertions(+)
> > 
> > diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
> > index c821279bd3..a2775b2f84 100644
> > --- a/gnu/packages/ibus.scm
> > +++ b/gnu/packages/ibus.scm
> > @@ -81,6 +81,7 @@ (define-module (gnu packages ibus)
> >  (define-public ibus-minimal
> >    (package
> >      (name "ibus")
> > +    (replacement ibus-minimal/fixed)
> >      (version "1.5.27")
> >      (source (origin
> >                (method url-fetch)
> > @@ -279,6 +280,23 @@ (define-public ibus
> >             (package-native-search-paths ibus-minimal)))
> >      (properties (alist-delete 'hidden? (package-properties ibus-
> > minimal)))))
> >  
> > +(define-public ibus-minimal/fixed
> 
> Is it useful to have the package 'public' at al here?  I think there
> are considerations so that the package gets built by the CI, but I'm
> not sure whether this applies to graft package (I guess it does). 
> Perhaps we should document these gotchas, as I can never remember
> myself.
I might have been cargo-culting the -public part from other
definitions.  Are grafts typically not exported?

Cheers
Maxim Cournoyer June 24, 2024, 2:13 a.m. UTC | #3
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Montag, dem 17.06.2024 um 15:55 -0400 schrieb Maxim Cournoyer:
>> Hi Liliana,
>> 
>> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>> 
>> > This fixes an issue, where IBus was not able to query emoji lists.
>> > See also <https://github.com/ibus/ibus/issues/2476>.
>> > 
>> > * gnu/packages/ibus.scm (ibus-minimal/fixed): New variable.
>> > (ibus-minimal): Add ibus-minimal/fixed as replacement.
>> > ---
>> >  gnu/packages/ibus.scm | 18 ++++++++++++++++++
>> >  1 file changed, 18 insertions(+)
>> > 
>> > diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
>> > index c821279bd3..a2775b2f84 100644
>> > --- a/gnu/packages/ibus.scm
>> > +++ b/gnu/packages/ibus.scm
>> > @@ -81,6 +81,7 @@ (define-module (gnu packages ibus)
>> >  (define-public ibus-minimal
>> >    (package
>> >      (name "ibus")
>> > +    (replacement ibus-minimal/fixed)
>> >      (version "1.5.27")
>> >      (source (origin
>> >                (method url-fetch)
>> > @@ -279,6 +280,23 @@ (define-public ibus
>> >             (package-native-search-paths ibus-minimal)))
>> >      (properties (alist-delete 'hidden? (package-properties ibus-
>> > minimal)))))
>> >  
>> > +(define-public ibus-minimal/fixed
>> 
>> Is it useful to have the package 'public' at al here?  I think there
>> are considerations so that the package gets built by the CI, but I'm
>> not sure whether this applies to graft package (I guess it does). 
>> Perhaps we should document these gotchas, as I can never remember
>> myself.
> I might have been cargo-culting the -public part from other
> definitions.  Are grafts typically not exported?

Not thinking about CI shenanigans, I think it's more logical that they
be private, since we want the users to use the grafted package, not the
graft itself (although in the end the result should be the same).
Liliana Marie Prikler June 24, 2024, 3:44 a.m. UTC | #4
Hi Maxim,

Am Sonntag, dem 23.06.2024 um 22:13 -0400 schrieb Maxim Cournoyer:
> > […] I might have been cargo-culting the -public part from other
> > definitions.  Are grafts typically not exported?
> 
> Not thinking about CI shenanigans, I think it's more logical that
> they be private, since we want the users to use the grafted package,
> not the graft itself (although in the end the result should be the
> same).

You mean that users end up accidentally discovering and using the wrong
ibus through CLI?  I don't think that's an issue for ibus-minimal,
though, since it's hidden anyway, and I do trust users who write the
files to be sensible here.

On that note, I think I remember a graft which had to be public to also
fix issues in certain dependent packages.  (I might have committed that
one myself and IIRC, it was meson).  Feel free to drop the -public part
from the ibus graft though; I had pushed it without resolving this
conversation.

Cheers
Maxim Cournoyer June 24, 2024, 4:50 a.m. UTC | #5
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Hi Maxim,
>
> Am Sonntag, dem 23.06.2024 um 22:13 -0400 schrieb Maxim Cournoyer:
>> > […] I might have been cargo-culting the -public part from other
>> > definitions.  Are grafts typically not exported?
>> 
>> Not thinking about CI shenanigans, I think it's more logical that
>> they be private, since we want the users to use the grafted package,
>> not the graft itself (although in the end the result should be the
>> same).
>
> You mean that users end up accidentally discovering and using the wrong
> ibus through CLI?  I don't think that's an issue for ibus-minimal,
> though, since it's hidden anyway, and I do trust users who write the
> files to be sensible here.
>
> On that note, I think I remember a graft which had to be public to also
> fix issues in certain dependent packages.  (I might have committed that
> one myself and IIRC, it was meson).  Feel free to drop the -public part
> from the ibus graft though; I had pushed it without resolving this
> conversation.

No big deal, but a reminder that we should add some proper grafting
guidelines to our doc.
diff mbox series

Patch

diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index c821279bd3..a2775b2f84 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -81,6 +81,7 @@  (define-module (gnu packages ibus)
 (define-public ibus-minimal
   (package
     (name "ibus")
+    (replacement ibus-minimal/fixed)
     (version "1.5.27")
     (source (origin
               (method url-fetch)
@@ -279,6 +280,23 @@  (define-public ibus
            (package-native-search-paths ibus-minimal)))
     (properties (alist-delete 'hidden? (package-properties ibus-minimal)))))
 
+(define-public ibus-minimal/fixed
+  ;; Fixes <https://github.com/ibus/ibus/issues/2476>.
+  ;; Ungraft on gnome-team, core-updates or a dedicated ungrafing branch.
+  (package
+    (inherit ibus-minimal)
+    (version "1.5.29")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/ibus/ibus/"
+                                  "releases/download/"
+                                  version "/ibus-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0vjybn3xq5sz616fdy21f5c4b4ajrj4wmfnbjqz6584xw887yiaa"))))
+    (inputs (modify-inputs (package-inputs ibus-minimal)
+              (prepend libdbusmenu)))))
+
 (define-public ibus-libpinyin
   (package
     (name "ibus-libpinyin")