Message ID | 20240320213619.11777-1-david.elsing@posteo.net |
---|---|
State | New |
Headers | show |
Series | [bug#69923] gnu: arcan-sdl: Add missing inputs. | expand |
Awesome! I just checked on my machine with the patch from 69866 and it still builds with that patch applied. It'll be great to have another package working! Also, just to clarify, I believe you mentioned on the call that you noticed that there was bundled source in this package which needs to be addressed. Is that something that you were planning on working on? Regards, Skyler
Hello, I believe arcan-sdl is built as part of the arcan package. I think I was planning to deprecate and remove it later as part of my arcan rework patches, but never got around to it. Is there a reason to keep it around and not use arcan? Perhaps it should be converted to an output for the main package instead, if there's a good reason? What do you think? Thanks, Ahmad Draidi
Hi,
David Elsing <david.elsing@posteo.net> skribis:
> * gnu/packages/arcan.scm (arcan-sdl)[inputs]: Add glu, libglvnd and mesa.
Applied, thanks!
Ludo’.
Hello, Ahmad Draidi <a.r.draidi@redscript.org> writes: > Is there a reason to keep it around and not use arcan? Perhaps it should be converted to an output for the main package instead, if > there's a good reason? I don't know what the motivation was to make a separate package with SDL1 and just looked why the build failed. The main package is built with SDL2, maybe that's the reason? Here is the original issue where arcan was added, you should probably ask them: https://issues.guix.gnu.org/34189. Best, David
diff --git a/gnu/packages/arcan.scm b/gnu/packages/arcan.scm index 4ca76edbec..dfc211ae9c 100644 --- a/gnu/packages/arcan.scm +++ b/gnu/packages/arcan.scm @@ -171,7 +171,7 @@ (define-public arcan-sdl (inputs (modify-inputs (package-inputs arcan) (delete "libdrm") - (prepend sdl))) + (prepend glu libglvnd mesa sdl))) (arguments `(,@(ensure-keyword-arguments (package-arguments arcan)