From edfc5be31a37f0c9ae0c5e7297a237645ab92e32 Mon Sep 17 00:00:00 2001
From: Benjamin Slade <slade@lambda-y.net>
Date: Mon, 18 Mar 2024 17:52:06 -0500
Subject: [PATCH] gnu: Add python-ical2orgpy.
* gnu/packages/python-xyz.scm (python-ical2orgpy): New variable
---
gnu/packages/python-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
@@ -17623,6 +17623,36 @@ (define-public python-execnet
(home-page "https://codespeak.net/execnet/")
(license license:expat))))
+(define-public python-ical2orgpy
+ (package
+ (name "python-ical2orgpy")
+ (version "0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ical2orgpy" version))
+ (sha256
+ (base32 "0a2ai78jzn250s1dlsimsfp6035421nrabj08xdlgsh7mb82gkap"))))
+ (build-system python-build-system)
+ (arguments
+ ;; Broken tests or cyclic dependecies with other packages.
+ '(#:phases (modify-phases %standard-phases
+ (delete 'sanity-check))
+ #:tests? #f))
+ (propagated-inputs (list python-click python-icalendar python-pytz
+ python-tzlocal python-recurring-ical-events))
+ (home-page "https://github.com/ical2org-py/ical2org.py")
+ (synopsis "Convert ical .ics file to org-mode")
+ (description
+ "This python script converts an ical calendar (for instance, as exported
+ from google calendar) into an org-mode document. It is conceived as a replacement of
+ the awk script located at
+@url{https://orgmode.org/worg/org-tutorials/org-google-sync.html}.
+ The main difference is that ical2orgpy correctly manages recurring events of
+ @dfn{yearly}, @dfn{daily} and @dfn{weekly} types. ical2orgpy duplicates all recurring
+ events falling into a specified time-frame into the exported org-document.")
+ (license license:gpl3+)))
+
(define-public python-recurring-ical-events
(package
(name "python-recurring-ical-events")
--
2.41.0