@@ -157,12 +157,11 @@ (define-public appmenu-gtk-module
"This package provides a global menu applet for use with desktop panels
such as mate-panel and xfce4-panel.")
(home-page "https://gitlab.com/vala-panel-project/vala-panel-appmenu")
- (license (list license:lgpl3))))
(define-public cairo
(package
(name "cairo")
- (version "1.16.0")
+ (version "1.18.0")
(source
(origin
(method url-fetch)
@@ -170,17 +169,16 @@ (define-public cairo
(string-append "https://cairographics.org/releases/cairo-"
version ".tar.xz"))
(sha256
- (base32 "0c930mk5xr2bshbdljv005j3j8zr47gqmkry3q6qgvqky6rjjysy"))
- (patches (search-patches
- "cairo-CVE-2018-19876.patch"
- "cairo-CVE-2020-35492.patch"))))
- (build-system glib-or-gtk-build-system)
- (outputs '("out" "doc"))
+ (base32
+ "0r0by563s75xyzz0d0j1nmjqmdrk2x9agk7r57p3v8vqp4v0ffi4"))))
+ (build-system meson-build-system)
(arguments
`(#:tests? #f ; see http://lists.gnu.org/archive/html/bug-guix/2013-06/msg00085.html
#:configure-flags
(list
- "--disable-static"
+ "-Dgtk_doc=true"
+ "-Dsymbol-lookup=disabled"
+ "-Dspectre=disabled"
;; XXX: To be enabled.
;; "--enable-gallium=yes"
;; "--enable-gl=yes"
@@ -189,15 +187,14 @@ (define-public cairo
;; "--enable-cogl=yes"
;; "--enable-directfb=yes"
;; "--enable-vg=yes"
- "--enable-tee=yes" ;needed for GNU IceCat
- "--enable-xml=yes" ;for cairo-xml support
- (string-append "--with-html-dir="
- (assoc-ref %outputs "doc")
- "/share/gtk-doc/html"))))
+ )))
(native-inputs
`(,@(if (target-hurd?)
'()
`(("gobject-introspection" ,gobject-introspection)))
+ ("gcc-13" ,gcc-13)
+ ("gtk-doc" ,gtk-doc)
+ ("docbook-xsl" ,docbook-xsl)
("pkg-config" ,pkg-config)
("python" ,python-wrapper)))
(inputs
@@ -236,6 +233,7 @@ (define-public cairo
(list
license:lgpl2.1+
license:mpl1.1))))
+ (license (list license:lgpl3))))
(define-public cairo-sans-poppler
;; Variant used to break the dependency cycle between Poppler and Cairo.