Message ID | 3eba9a4c0ca80fa57106cd50ba827915b9bd91a0.1691416969.git.iyzsong@member.fsf.org |
---|---|
State | New |
Headers | show |
Series | [bug#65126] gnu: exiv2: Get rid of reference to GCC. | expand |
Hi! iyzsong@envs.net skribis: > From: 宋文武 <iyzsong@member.fsf.org> > > This fixes <https://issues.guix.gnu.org/57677>. s/This fixes/Fixes/, for consistency. > + (add-after 'unpack 'patch-gcc-reference > + (lambda _ > + ;; _GLIBCXX_ASSERTIONS brings reference to GCC. > + (substitute* "cmake/compilerFlags.cmake" > + (("add_compile_options[(]-Wp,-D_GLIBCXX_ASSERTIONS[)]") > + "")))) Well done! According to <https://gcc.gnu.org/onlinedocs/libstdc++/manual/using_macros.html>, ‘_GLIBCXX_ASSERTIONS’ enables various run-time checks; I guess disabling it is acceptable. So… LGTM! Thanks, Ludo’.
Ludovic Courtès <ludo@gnu.org> skribis:
> So… LGTM!
Well, wait for <https://qa.guix.gnu.org/issue/65126> to be done.
Ludo’.
Ludovic Courtès <ludo@gnu.org> writes:
> Well, wait for <https://qa.guix.gnu.org/issue/65126> to be done.
Hello, I think CI is stucking here.
On https://qa.guix.gnu.org/patches we get:
Builds for new patch series suspended as master branch substitute
availability is low for: i686-linux
In this case should I first fix broken builds for i686-linux?
Also will CI able to automatically rebase the patch upon latest master?
If the patch was built with old base, it won't have substitutes after
merge even it's green.
宋文武 <iyzsong@envs.net> writes: > Ludovic Courtès <ludo@gnu.org> writes: > >> Well, wait for <https://qa.guix.gnu.org/issue/65126> to be done. > > Hello, I think CI is stucking here. I'm going to answer replacing CI with qa.guix.gnu.org, as I think that makes the questions make more sense. > On https://qa.guix.gnu.org/patches we get: > Builds for new patch series suspended as master branch substitute > availability is low for: i686-linux > In this case should I first fix broken builds for i686-linux? I think substitute availability is below 80% for i686-linux because the bordeaux build farm is still catching up. There's a shepherd issue on milano-guix-1, so that's reduced the resources available for x86_64-linux and i686-linux builds. QA waits until substitute availability is good before submitting builds as that avoids submitting builds when they probably won't happen for a while, given the bordeaux build farm will be busy with the master branch builds instead. Ideally more changes would be processed by QA and built fully before being merged, so that substitutes are available when they're merged. > Also will CI able to automatically rebase the patch upon latest master? > If the patch was built with old base, it won't have substitutes after > merge even it's green. The qa-frontpage does automatically rebase patches, although there's probably a lot of room for improvement to better detect when a patch series could do with rebasing.
Hi 宋文武, Ludovic Courtès <ludo@gnu.org> skribis: > Ludovic Courtès <ludo@gnu.org> skribis: > >> So… LGTM! > > Well, wait for <https://qa.guix.gnu.org/issue/65126> to be done. Looks like it’s all green now, go ahead! :-) Ludo’.
Ludovic Courtès <ludo@gnu.org> writes: > Hi 宋文武, > > Ludovic Courtès <ludo@gnu.org> skribis: > >> Ludovic Courtès <ludo@gnu.org> skribis: >> >>> So… LGTM! >> >> Well, wait for <https://qa.guix.gnu.org/issue/65126> to be done. > > Looks like it’s all green now, go ahead! :-) Pushed now, thanks!
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm index 3336e38852..1dbf3cbdd6 100644 --- a/gnu/packages/image.scm +++ b/gnu/packages/image.scm @@ -1511,6 +1511,12 @@ (define-public exiv2 "-DEXIV2_ENABLE_BMFF=ON") #:phases (modify-phases %standard-phases + (add-after 'unpack 'patch-gcc-reference + (lambda _ + ;; _GLIBCXX_ASSERTIONS brings reference to GCC. + (substitute* "cmake/compilerFlags.cmake" + (("add_compile_options[(]-Wp,-D_GLIBCXX_ASSERTIONS[)]") + "")))) (add-after 'install 'delete-static-libraries (lambda* (#:key outputs #:allow-other-keys) (let* ((out (assoc-ref outputs "out"))
From: 宋文武 <iyzsong@member.fsf.org> This fixes <https://issues.guix.gnu.org/57677>. * gnu/packages/image.scm (exiv2)[arguments]: Add phase to remove _GLIBCXX_ASSERTIONS from compiler flags. --- gnu/packages/image.scm | 6 ++++++ 1 file changed, 6 insertions(+) base-commit: 56667ee55cd7f3368cbff169352fe440f4f93da5