@@ -12,6 +12,7 @@
;;; Copyright © 2020 Sergey Trofimov <sarg@sarg.org.ru>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2023 Camilo Q.S. (Distopico) <distopico@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,6 +39,7 @@ (define-module (gnu packages android)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system trivial)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
@@ -721,6 +723,28 @@ (define-public fastboot
"This package provides @command{fastboot}, a tool to upload file system images to Android devices.")
(license license:asl2.0)))
+(define-public sdkmanager
+ (package
+ (name "sdkmanager")
+ (version "0.6.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "sdkmanager" version ".tar.gz"))
+ (sha256
+ (base32
+ "11as7n2mj3nbqsqb3ivyv9985n73i022s748qvjg36cs8ig50afx"))))
+ (build-system pyproject-build-system)
+ (inputs (list python-requests python-argcomplete python-urllib3))
+ (home-page "https://gitlab.com/fdroid/sdkmanager")
+ (synopsis
+ "Replacement for Android sdkmanager written in Python")
+ (description
+ "This package provides a drop-in replacement for sdkmanager from
+the Android SDK. It is written in Python and part of the F-Droid
+project. It implements the exact API of the Android sdkmanager command
+line. The project also attempts to maintain the same terminal output.")
+ (license license:agpl3+)))
+
(define-public android-udev-rules
(package
(name "android-udev-rules")
Hello, thanks for the new package! According to our naming scheme, we should either call it "sdkmanager" (the upstream name), or "python-sdkmanager" (as a Python library). Given that it is mainly an executable, I opted for the first one; also since the second one is a bit misleading (it does not manage SDKs for python). I have removed the propagated input gnutls; propagated inputs should be used very sparingly, and so far I did not see where it would be required. I am not sure the package works. When running sdkmanager --sdk_root /tmp/sdk --install it complains that it has no rights on /opt/android-sdk. I was just guessing how it works from "sdkmanager --help"; should --sdk_root not set the place where to install the SDKs? "sdkmanager --list" does seem to work. I am attaching a new version of the patch; what do you think? Andreas From fe501c98e105a0ee76b34737d8071608f130c76b Mon Sep 17 00:00:00 2001 Message-ID: <fe501c98e105a0ee76b34737d8071608f130c76b.1690203197.git.andreas@enge.fr> From: Distopico <distopico@riseup.net> Date: Sun, 23 Jul 2023 13:41:32 -0500 Subject: [PATCH] gnu: Add sdkmanager. * gnu/packages/android.scm (sdkmanager): New variable. Co-authored-by: Andreas Enge <andreas@enge.fr> --- gnu/packages/android.scm | 24 ++++++++++++++++++++++++ 1 file changed, 24 insertions(+) base-commit: cf9904bcc8dd03e73675475bb4d8746dc434e415