diff mbox series

[bug#63527,v5,05/11] gnu: parted: Support building for the Hurd.

Message ID 71a14f2a5b28b90b2a996b1afab6e39c101dfa1d.1684855847.git.janneke@gnu.org
State New
Headers show
Series [bug#63527,v5,01/11] gnu: Add libpciaccess-0.17. | expand

Commit Message

Janneke Nieuwenhuizen May 23, 2023, 3:47 p.m. UTC
* gnu/packages/disk.scm (parted)[inputs]: Remove lvm2, add hurd-shouldbeinlibc
when building for the Hurd.
[arguments]: Add configure-flag '--disable-device-mapper' when building for
the Hurd.
---
 gnu/packages/disk.scm | 19 ++++++++++++++-----
 1 file changed, 14 insertions(+), 5 deletions(-)

Comments

Ludovic Courtès May 24, 2023, 9:13 a.m. UTC | #1
Janneke Nieuwenhuizen <janneke@gnu.org> skribis:

> * gnu/packages/disk.scm (parted)[inputs]: Remove lvm2, add hurd-shouldbeinlibc
> when building for the Hurd.
> [arguments]: Add configure-flag '--disable-device-mapper' when building for
> the Hurd.

[...]

>      (arguments
> -     (list #:phases
> +     (append
> +      (if (hurd-target?)
> +          '(#:configure-flags '("--disable-device-mapper"))
> +          '())
> +      (list
> +       #:phases

Slightly more visually appealing:

  (list #:configure-flags (if (hurd-target?)
                              #~'("--disable-device-mapper")
                              #~'())
        #:phases …)

:-)

Ludo’.
Janneke Nieuwenhuizen May 24, 2023, 9:24 a.m. UTC | #2
Ludovic Courtès writes:

> Janneke Nieuwenhuizen <janneke@gnu.org> skribis:
>
[..]

> Slightly more visually appealing:
>
>   (list #:configure-flags (if (hurd-target?)
>                               #~'("--disable-device-mapper")
>                               #~'())
>         #:phases …)
>
> :-)

Nice   I couldn't figure this one out, thanks!

Greetings,
Janneke
diff mbox series

Patch

diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 894a542171..760e9cd8f6 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -4,7 +4,7 @@ 
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016, 2018–2022 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2016, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2016, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
@@ -67,6 +67,7 @@  (define-module (gnu packages disk)
   #:use-module (gnu packages graphics)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages guile)
+  #:use-module (gnu packages hurd)
   #:use-module (gnu packages image)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages ncurses)
@@ -249,17 +250,25 @@  (define-public parted
                 "18h51i3x5cbqhlj5rm23m9sfw63gaaby5czln5w6qpqj3ifdsf29"))))
     (build-system gnu-build-system)
     (arguments
-     (list #:phases
+     (append
+      (if (hurd-target?)
+          '(#:configure-flags '("--disable-device-mapper"))
+          '())
+      (list
+       #:phases
        #~(modify-phases %standard-phases
            (add-after 'unpack 'fix-locales-and-python
              (lambda _
                (substitute* "tests/t0251-gpt-unicode.sh"
                  (("C.UTF-8") "en_US.utf8")) ;not in Glibc locales
                (substitute* "tests/msdos-overlap"
-                 (("/usr/bin/python") (which "python"))))))))
+                 (("/usr/bin/python") (which "python")))))))))
     (inputs
-     (list lvm2 readline
-           `(,util-linux "lib")))
+     `(,@(if (hurd-target?)
+             (list hurd-shouldbeinlibc)
+             (list lvm2))
+       ,readline
+       (,util-linux "lib")))
     (native-inputs
      (list gettext-minimal