diff mbox series

[bug#63527,v4,7/8] services: childhurd: Bump default qemu memory to 2048MB.

Message ID 11e63f303ba42376ebc029c67f13b59bdb0af263.1684402361.git.janneke@gnu.org
State New
Headers show
Series Rumpdisk support for the Hurd, really! | expand

Commit Message

Janneke Nieuwenhuizen May 18, 2023, 9:39 a.m. UTC
When booting with pci-arbiter and rumpdisk and using 1024MB of memory for
qemu, booting hangs, or seems to hang, at the end of the rumpdisk boot
messages.  At least 1200MB is required, currently.

* gnu/services/virtualization.scm (<hurd-vm-configuration>)[memory-size]: Bump
to 2048.
* gnu/system/examples/bare-hurd.tmpl: Suggest using 2048 here too.  Update
example `guix system image' and "qemu" command lines too.
---
 gnu/services/virtualization.scm    | 4 ++--
 gnu/system/examples/bare-hurd.tmpl | 4 ++--
 2 files changed, 4 insertions(+), 4 deletions(-)

Comments

Ludovic Courtès May 18, 2023, 5:20 p.m. UTC | #1
Janneke Nieuwenhuizen <janneke@gnu.org> skribis:

> When booting with pci-arbiter and rumpdisk and using 1024MB of memory for
> qemu, booting hangs, or seems to hang, at the end of the rumpdisk boot
> messages.  At least 1200MB is required, currently.
>
> * gnu/services/virtualization.scm (<hurd-vm-configuration>)[memory-size]: Bump
> to 2048.
> * gnu/system/examples/bare-hurd.tmpl: Suggest using 2048 here too.  Update
> example `guix system image' and "qemu" command lines too.

Sounds a bit fishy.  :-)

Does Debian resort to a similar workaround?

Ludo’.
Janneke Nieuwenhuizen May 19, 2023, 9:30 a.m. UTC | #2
Ludovic Courtès writes:

> Janneke Nieuwenhuizen <janneke@gnu.org> skribis:
>
>> When booting with pci-arbiter and rumpdisk and using 1024MB of memory for
>> qemu, booting hangs, or seems to hang, at the end of the rumpdisk boot
>> messages.  At least 1200MB is required, currently.
>>
>> * gnu/services/virtualization.scm (<hurd-vm-configuration>)[memory-size]: Bump
>> to 2048.
>> * gnu/system/examples/bare-hurd.tmpl: Suggest using 2048 here too.  Update
>> example `guix system image' and "qemu" command lines too.
>
> Sounds a bit fishy.  :-)
>
> Does Debian resort to a similar workaround?

Yes, Debian has the same problem, the latest debian image
(https://cdimage.debian.org/cdimage/ports/latest/hurd-i386/debian-hurd-20220824.img)
hangs in an identical way.

See https://logs.guix.gnu.org/hurd/2023-05-18.log#091300

youpi seid "rumpdisk is very eaty, we need to fix that"

Greetings,
Janneke
diff mbox series

Patch

diff --git a/gnu/services/virtualization.scm b/gnu/services/virtualization.scm
index 2e311e3813..886b73f8c7 100644
--- a/gnu/services/virtualization.scm
+++ b/gnu/services/virtualization.scm
@@ -1,7 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2017 Ryan Moe <ryan.moe@gmail.com>
 ;;; Copyright © 2018, 2020-2022 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2020,2021 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2020, 2021, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2021 Timotej Lazar <timotej.lazar@araneo.si>
 ;;; Copyright © 2022 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2022 Leo Nikkilä <hello@lnikki.la>
@@ -1100,7 +1100,7 @@  (define-record-type* <hurd-vm-configuration>
   (disk-size   hurd-vm-configuration-disk-size          ;number or 'guess
                (default 'guess))
   (memory-size hurd-vm-configuration-memory-size        ;number
-               (default 512))
+               (default 2048))
   (options     hurd-vm-configuration-options            ;list of string
                (default `("--snapshot")))
   (id          hurd-vm-configuration-id                 ;#f or integer [1..]
diff --git a/gnu/system/examples/bare-hurd.tmpl b/gnu/system/examples/bare-hurd.tmpl
index f0dd0cf742..463c7ee798 100644
--- a/gnu/system/examples/bare-hurd.tmpl
+++ b/gnu/system/examples/bare-hurd.tmpl
@@ -5,12 +5,12 @@ 
 
 ;; To build a disk image for a virtual machine, do
 ;;
-;;     ./pre-inst-env guix system image --target=i586-pc-gnu \
+;;     ./pre-inst-env guix system image --image-type=hurd-raw \
 ;;         gnu/system/examples/bare-hurd.tmpl
 ;;
 ;; You may run it like so
 ;;
-;;     guix environment --ad-hoc qemu -- qemu-system-i386 -enable-kvm -m 512M \
+;;     guix shell qemu -- qemu-system-i386 -enable-kvm -m 2048 \
 ;;      -device rtl8139,netdev=net0 -netdev user,id=net0,hostfwd=tcp:127.0.0.1:10022-:2222 \
 ;;      -snapshot -hda <the-image>
 ;;