diff mbox series

[bug#62801,3/4] gnu: Add python-ccdproc.

Message ID 20230412210529.30189-3-sharlatanus@gmail.com
State New
Headers show
Series : gnu: python-astroalign: Update to 2.4.2. | expand

Commit Message

Sharlatan Hellseher April 12, 2023, 9:05 p.m. UTC
* gnu/packages/astronomy.scm (python-ccdproc): New variable.
---
 gnu/packages/astronomy.scm | 33 ++++++++++++++++++++++++++++++++-
 1 file changed, 32 insertions(+), 1 deletion(-)

Comments

Maxim Cournoyer April 20, 2023, 1:55 a.m. UTC | #1
Hello,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

> * gnu/packages/astronomy.scm (python-ccdproc): New variable.
> ---
>  gnu/packages/astronomy.scm | 33 ++++++++++++++++++++++++++++++++-
>  1 file changed, 32 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
> index f162be6006..9961e19695 100644
> --- a/gnu/packages/astronomy.scm
> +++ b/gnu/packages/astronomy.scm
> @@ -5,7 +5,7 @@
>  ;;; Copyright © 2019 by Amar Singh <nly@disroot.org>
>  ;;; Copyright © 2020 R Veera Kumar <vkor@vkten.in>
>  ;;; Copyright © 2020, 2021 Guillaume Le Vaillant <glv@posteo.net>
> -;;; Copyright © 2021, 2022, 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
> +;;; Copyright © 2021-2023 Sharlatan Hellseher <sharlatanus@gmail.com>
>  ;;; Copyright © 2021, 2022 Vinicius Monego <monego@posteo.net>
>  ;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
>  ;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
> @@ -1350,6 +1350,37 @@ (define-public python-astroscrappy
>  specifically in the C code.")
>      (license license:bsd-3)))
>  
> +(define-public python-ccdproc
> +  (package
> +    (name "python-ccdproc")
> +    (version "2.4.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "ccdproc" version))
> +       (sha256
> +        (base32 "0fy1sni87cr05dkljd8wb7vgh7z9agh8wv5kiagxcpbcf8l06jv1"))))
> +    (build-system pyproject-build-system)
> +    (arguments
> +     ;; FIXME: Test failed a lot with: DeprecationWarning: distutils Version
> +     ;; classes are deprecated. Use packaging.version instead.

Please report problem upstream, so that it can be fixed and its
resolution tracked.  If it already is reported, link to it here, with a
"(see: https://...)" trailing bit to the explanatory comment.

> +     (list #:tests? #f))
> +    (native-inputs
> +     (list python-memory-profiler python-pytest-astropy))
> +    (propagated-inputs
> +     (list python-astropy
> +           python-astroscrappy
> +           python-numpy
> +           python-reproject
> +           python-scikit-image
> +           python-scipy))
> +    (home-page "http://ccdproc.readthedocs.io/")
> +    (synopsis "Basic data reductions of CCD images")
> +    (description "The ccdproc package provides many of the necessary tools for
> +processing of CCD images built on a framework to provide error propagation and
> +bad pixel tracking throughout the reduction process.")
> +    (license license:bsd-3)))

Looks fine otherwise!
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index f162be6006..9961e19695 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -5,7 +5,7 @@ 
 ;;; Copyright © 2019 by Amar Singh <nly@disroot.org>
 ;;; Copyright © 2020 R Veera Kumar <vkor@vkten.in>
 ;;; Copyright © 2020, 2021 Guillaume Le Vaillant <glv@posteo.net>
-;;; Copyright © 2021, 2022, 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2021-2023 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2021, 2022 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
@@ -1350,6 +1350,37 @@  (define-public python-astroscrappy
 specifically in the C code.")
     (license license:bsd-3)))
 
+(define-public python-ccdproc
+  (package
+    (name "python-ccdproc")
+    (version "2.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "ccdproc" version))
+       (sha256
+        (base32 "0fy1sni87cr05dkljd8wb7vgh7z9agh8wv5kiagxcpbcf8l06jv1"))))
+    (build-system pyproject-build-system)
+    (arguments
+     ;; FIXME: Test failed a lot with: DeprecationWarning: distutils Version
+     ;; classes are deprecated. Use packaging.version instead.
+     (list #:tests? #f))
+    (native-inputs
+     (list python-memory-profiler python-pytest-astropy))
+    (propagated-inputs
+     (list python-astropy
+           python-astroscrappy
+           python-numpy
+           python-reproject
+           python-scikit-image
+           python-scipy))
+    (home-page "http://ccdproc.readthedocs.io/")
+    (synopsis "Basic data reductions of CCD images")
+    (description "The ccdproc package provides many of the necessary tools for
+processing of CCD images built on a framework to provide error propagation and
+bad pixel tracking throughout the reduction process.")
+    (license license:bsd-3)))
+
 (define-public python-cdflib
   (package
     (name "python-cdflib")