diff mbox series

[bug#60098,core-updates] gnu: boost: Update to 1.81.0.

Message ID 72566ac57a512f4f1f7fc3c5243b93ae26f11620.1671034735.git.code@greghogan.com
State New
Headers show
Series [bug#60098,core-updates] gnu: boost: Update to 1.81.0. | expand

Commit Message

Greg Hogan Dec. 15, 2022, 6:57 p.m. UTC
* gnu/packages/boost.scm (boost): Update to 1.81.0.
[source](patches): Remove old upstream patches.
---
 gnu/packages/boost.scm | 30 ++----------------------------
 1 file changed, 2 insertions(+), 28 deletions(-)

Comments

Greg Hogan April 19, 2023, 3:10 p.m. UTC | #1
On Thu, Dec 15, 2022 at 1:57 PM Greg Hogan <code@greghogan.com> wrote:
>
> * gnu/packages/boost.scm (boost): Update to 1.81.0.
> [source](patches): Remove old upstream patches.
> ---
>  gnu/packages/boost.scm | 30 ++----------------------------
>  1 file changed, 2 insertions(+), 28 deletions(-)
>
> diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
> index d2b676cc73..a83b1cad8f 100644
> --- a/gnu/packages/boost.scm
> +++ b/gnu/packages/boost.scm
> @@ -68,41 +68,15 @@ (define (boost-patch name version hash)
>  (define-public boost
>    (package
>      (name "boost")
> -    (version "1.80.0")
> +    (version "1.81.0")
>      (source (origin
>                (method url-fetch)
>                (uri (string-append "https://boostorg.jfrog.io/artifactory/main/release/"
>                                    version "/source/boost_"
>                                    (version-with-underscores version) ".tar.bz2"))
> -              (patches
> -               (list (boost-patch
> -                      ;; Boost.Filesystem directory iterators may fail to
> -                      ;; construct for a network share on Windows prior to 10:
> -                      ;; https://github.com/boostorg/filesystem/pull/246,
> -                      ;; https://github.com/boostorg/filesystem/issues/245
> -                      "0001-filesystem-win-fix-dir-it-net-share.patch" version
> -                      "067hhylqkzzdbqzc1hkbpaqmvz248lxqrdhb2yi6iq9qabsik3lk")
> -                     (boost-patch
> -                      ;; In Boost.Filesystem on Windows, weakly_canonical fails
> -                      ;; to process paths that start with the "\\?\" prefix:
> -                      ;; https://github.com/boostorg/filesystem/issues/247
> -                      "0002-filesystem-fix-weakly-canonical-long-paths.patch" version
> -                      "00w3albf8527glclx85p5b2ml3vr06xpwwmfyzg005v1cp8avcpi")
> -                     (boost-patch
> -                      ;; Boost.Unordered containers are not in a valid state
> -                      ;; after moving:
> -                      ;; https://github.com/boostorg/unordered/issues/139
> -                      "0003-unordered-valid-after-move.patch" version
> -                      "0dw839w22cawqawfpsx7j7v9y0x2vn66m732iidpxvdxbjn2kzva")
> -                     (boost-patch
> -                      ;; Fixed a missing include on POSIX systems that don't
> -                      ;; support *at APIs:
> -                      ;; https://github.com/boostorg/filesystem/issues/250
> -                      "0004-filesystem-posix-fix-no-at-apis-missing-include.patch" version
> -                      "09k8k3b1306jkjls12wfghj820n828j6aaxzmcr0wpnjhp8fzi1v")))
>                (sha256
>                 (base32
> -                "1h00qp4z5k6lfz310xjwsmqs8fwxi6ngas51169cafz4h9fmc68y"))))
> +                "1ylrmxmrh9a7xnvxh3llibr8cw91gi5giwmllc2cmk7v03cyxzki"))))
>      (build-system gnu-build-system)
>      (inputs
>       (append
> --
> 2.38.1

Closing as Boost 1.82.0 has been released.
  https://www.boost.org/users/history/version_1_82_0.html
diff mbox series

Patch

diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index d2b676cc73..a83b1cad8f 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -68,41 +68,15 @@  (define (boost-patch name version hash)
 (define-public boost
   (package
     (name "boost")
-    (version "1.80.0")
+    (version "1.81.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://boostorg.jfrog.io/artifactory/main/release/"
                                   version "/source/boost_"
                                   (version-with-underscores version) ".tar.bz2"))
-              (patches
-               (list (boost-patch
-                      ;; Boost.Filesystem directory iterators may fail to
-                      ;; construct for a network share on Windows prior to 10:
-                      ;; https://github.com/boostorg/filesystem/pull/246,
-                      ;; https://github.com/boostorg/filesystem/issues/245
-                      "0001-filesystem-win-fix-dir-it-net-share.patch" version
-                      "067hhylqkzzdbqzc1hkbpaqmvz248lxqrdhb2yi6iq9qabsik3lk")
-                     (boost-patch
-                      ;; In Boost.Filesystem on Windows, weakly_canonical fails
-                      ;; to process paths that start with the "\\?\" prefix:
-                      ;; https://github.com/boostorg/filesystem/issues/247
-                      "0002-filesystem-fix-weakly-canonical-long-paths.patch" version
-                      "00w3albf8527glclx85p5b2ml3vr06xpwwmfyzg005v1cp8avcpi")
-                     (boost-patch
-                      ;; Boost.Unordered containers are not in a valid state
-                      ;; after moving:
-                      ;; https://github.com/boostorg/unordered/issues/139
-                      "0003-unordered-valid-after-move.patch" version
-                      "0dw839w22cawqawfpsx7j7v9y0x2vn66m732iidpxvdxbjn2kzva")
-                     (boost-patch
-                      ;; Fixed a missing include on POSIX systems that don't
-                      ;; support *at APIs:
-                      ;; https://github.com/boostorg/filesystem/issues/250
-                      "0004-filesystem-posix-fix-no-at-apis-missing-include.patch" version
-                      "09k8k3b1306jkjls12wfghj820n828j6aaxzmcr0wpnjhp8fzi1v")))
               (sha256
                (base32
-                "1h00qp4z5k6lfz310xjwsmqs8fwxi6ngas51169cafz4h9fmc68y"))))
+                "1ylrmxmrh9a7xnvxh3llibr8cw91gi5giwmllc2cmk7v03cyxzki"))))
     (build-system gnu-build-system)
     (inputs
      (append