diff mbox series

[bug#62418] gnu: Update to 13.1.

Message ID 20230407193738.268958-1-code@greghogan.com
State New
Headers show
Series [bug#62418] gnu: Update to 13.1. | expand

Commit Message

Greg Hogan April 7, 2023, 7:37 p.m. UTC
* gnu/packages/gdb.scm (gdb-12): Rename to ...
(gdb-13): ... and update to 13.1.
(avr-gdb): Inherit from GDB-13.
---
 gnu/packages/gdb.scm | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

Comments

Simon Tournier April 8, 2023, 9:40 a.m. UTC | #1
Hi,

THe commit header line is:

    gnu: Update to 13.1.

and ’gdb’ seems missing.


On Fri, 07 Apr 2023 at 19:37, Greg Hogan <code@greghogan.com> wrote:
> * gnu/packages/gdb.scm (gdb-12): Rename to ...
> (gdb-13): ... and update to 13.1.
> (avr-gdb): Inherit from GDB-13.

Naive question, why GDB@12 is removed and not instead GDB@11?

Cheers,
simon
Greg Hogan April 10, 2023, 6:36 p.m. UTC | #2
On Sat, Apr 8, 2023 at 5:41 AM Simon Tournier <zimon.toutoune@gmail.com> wrote:
>
> Hi,
>
> THe commit header line is:
>
>     gnu: Update to 13.1.
>
> and ’gdb’ seems missing.

Good observation. Will submit a second version of the patch.

> On Fri, 07 Apr 2023 at 19:37, Greg Hogan <code@greghogan.com> wrote:
> > * gnu/packages/gdb.scm (gdb-12): Rename to ...
> > (gdb-13): ... and update to 13.1.
> > (avr-gdb): Inherit from GDB-13.
>
> Naive question, why GDB@12 is removed and not instead GDB@11?

gdb@11 has 6811 dependent packages.
Simon Tournier April 11, 2023, 8:07 a.m. UTC | #3
Hi,

On Mon, 10 Apr 2023 at 14:36, Greg Hogan <code@greghogan.com> wrote:

>> On Fri, 07 Apr 2023 at 19:37, Greg Hogan <code@greghogan.com> wrote:
>> > * gnu/packages/gdb.scm (gdb-12): Rename to ...
>> > (gdb-13): ... and update to 13.1.
>> > (avr-gdb): Inherit from GDB-13.
>>
>> Naive question, why GDB@12 is removed and not instead GDB@11?
>
> gdb@11 has 6811 dependent packages.

Well, the usual way when several versions are around and when one is
used by many is to name the other with the suffix ’-next’.

See python-numpy-next, emacs-next, etc.


Cheers,
simon
Greg Hogan April 11, 2023, 1:43 p.m. UTC | #4
On Tue, Apr 11, 2023 at 4:37 AM Simon Tournier <zimon.toutoune@gmail.com> wrote:
>
> > gdb@11 has 6811 dependent packages.
>
> Well, the usual way when several versions are around and when one is
> used by many is to name the other with the suffix ’-next’.
>
> See python-numpy-next, emacs-next, etc.

I had thought the preferred way was to suffix the internal version
with '/pinned' rather than suffixing and reverting the user-facing
package name, but hopefully the need to do this is significantly
reduced with the switch from core-updates and staging to feature
branches.

If it's an issue of stability or compatibility then '-next' is the
sensible approach.
Greg Hogan April 18, 2023, 8:43 p.m. UTC | #5
On Tue, Apr 11, 2023 at 9:43 AM Greg Hogan <code@greghogan.com> wrote:
>
> On Tue, Apr 11, 2023 at 4:37 AM Simon Tournier <zimon.toutoune@gmail.com> wrote:
> >
> > > gdb@11 has 6811 dependent packages.
> >
> > Well, the usual way when several versions are around and when one is
> > used by many is to name the other with the suffix ’-next’.
> >
> > See python-numpy-next, emacs-next, etc.
>
> I had thought the preferred way was to suffix the internal version
> with '/pinned' rather than suffixing and reverting the user-facing
> package name, but hopefully the need to do this is significantly
> reduced with the switch from core-updates and staging to feature
> branches.
>
> If it's an issue of stability or compatibility then '-next' is the
> sensible approach.

I see that Ludo' added the '/pinned' suffix in core-updates 6b5c21e0.

This patch is successfully building on QA.
diff mbox series

Patch

diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index fd0bc80e44..6f7b3929e3 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -149,17 +149,17 @@  (define-public gdb-11
 written in C, C++, Ada, Objective-C, Pascal and more.")
     (license gpl3+)))
 
-(define-public gdb-12
+(define-public gdb-13
   (package
     (inherit gdb-11)
-    (version "12.1")
+    (version "13.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnu/gdb/gdb-"
                                   version ".tar.xz"))
               (sha256
                (base32
-                "1vczsqcbh5y0gx7qrclpna0qzx26sk7lra6y8qzxam1biyzr65qf"))))))
+                "184m5rp5gfkf5i8b707l2hf238m2vmjx70jqn4mbx9k9ip0xanhi"))))))
 
 (define-public gdb
   ;; This is the fixed version that packages depend on.  Update it rarely
@@ -173,7 +173,7 @@  (define-public gdb-minimal
                   '("libxml2" "ncurses" "python-wrapper" "source-highlight")))))
 
 (define-public avr-gdb
-  (package/inherit gdb-12
+  (package/inherit gdb-13
     (name "avr-gdb")
     (arguments
      `(#:configure-flags
@@ -182,7 +182,7 @@  (define-public avr-gdb
              "--enable-languages=c,c++"
              "--with-system-readline"
              "--enable-source-highlight")
-       ,@(package-arguments gdb-12)))
+       ,@(package-arguments gdb-13)))
     (synopsis "The GNU Debugger for AVR")
     (description
      "GDB is the GNU debugger.  With it, you can monitor what a program is