diff mbox series

[bug#62244] etc: Add gnome team.

Message ID a9f2c332f334d85ab758105ec8398fd53f87de32.camel@gmail.com
State New
Headers show
Series [bug#62244] etc: Add gnome team. | expand

Commit Message

Liliana Marie Prikler March 17, 2023, 5:37 p.m. UTC
* etc/teams.scm.in (gnome): New team.
("Liliana Marie Prikler"): Add to gnome.
---
Hi folks,

to get effort for GNOME 44 rolling while also recognizing the burden this
puts on folks, I've decided to add a gnome team to our teams.scm.

To those in Debbugs CC – you know who you are ;) – I've added you to CC,
because you've contributed changes to the mentioned scope since 2022.
If you'd like to be added to the team from the first commit, please
reply; otherwise feel free to add yourself at your convenience.

Cheers

 etc/teams.scm.in | 17 ++++++++++++++++-
 1 file changed, 16 insertions(+), 1 deletion(-)

Comments

Raghav Gururajan March 19, 2023, 1:59 p.m. UTC | #1
Liliana,

Count me in. :-)

Regards,
RG.

On 17/03/23 13:37, Liliana Marie Prikler wrote:
> * etc/teams.scm.in (gnome): New team.
> ("Liliana Marie Prikler"): Add to gnome.
> ---
> Hi folks,
> 
> to get effort for GNOME 44 rolling while also recognizing the burden this
> puts on folks, I've decided to add a gnome team to our teams.scm.
> 
> To those in Debbugs CC – you know who you are ;) – I've added you to CC,
> because you've contributed changes to the mentioned scope since 2022.
> If you'd like to be added to the team from the first commit, please
> reply; otherwise feel free to add yourself at your convenience.
> 
> Cheers
> 
>   etc/teams.scm.in | 17 ++++++++++++++++-
>   1 file changed, 16 insertions(+), 1 deletion(-)
> 
> diff --git a/etc/teams.scm.in b/etc/teams.scm.in
> index e582993450..9698c8b04c 100644
> --- a/etc/teams.scm.in
> +++ b/etc/teams.scm.in
> @@ -436,6 +436,21 @@ (define-team reproduciblebuilds
>           "Reproducible Builds tooling and issues that affect any guix packages."
>           #:scope (list "gnu/packages/diffoscope.scm")))
>   
> +(define-team gnome
> +  (team 'gnome
> +        #:name "Gnome team"
> +        #:description
> +        "The Gnome desktop environment, along with core technologies such as
> +GLib/GIO, GTK, GStreamer and Webkit."
> +        #:scope (list "gnu/packages/glib.scm"
> +                      "gnu/packages/gstreamer.scm"
> +                      "gnu/packages/gtk.scm"
> +                      "gnu/packages/gnome.scm"
> +                      "gnu/packages/gnome-xyz.scm"
> +                      "gnu/packages/webkit.scm"
> +                      "guix/build/glib-or-gtk-build-system.scm"
> +                      "guix/build/meson-build-system.scm")))
> +
>   (define-team xfce
>     (team 'xfce
>           #:name "Xfce team"
> @@ -511,7 +526,7 @@ (define-member (person "Florian Pelz"
>   
>   (define-member (person "Liliana Marie Prikler"
>                          "liliana.prikler@gmail.com")
> -  emacs games)
> +  emacs games gnome)
>   
>   (define-member (person "Ricardo Wurmus"
>                          "rekado@elephly.net")
Maxim Cournoyer March 29, 2023, 1:08 a.m. UTC | #2
Hello,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * etc/teams.scm.in (gnome): New team.
> ("Liliana Marie Prikler"): Add to gnome.
> ---
> Hi folks,
>
> to get effort for GNOME 44 rolling while also recognizing the burden this
> puts on folks, I've decided to add a gnome team to our teams.scm.
>
> To those in Debbugs CC – you know who you are ;) – I've added you to CC,
> because you've contributed changes to the mentioned scope since 2022.
> If you'd like to be added to the team from the first commit, please
> reply; otherwise feel free to add yourself at your convenience.

LGTM.  Count me in too!
diff mbox series

Patch

diff --git a/etc/teams.scm.in b/etc/teams.scm.in
index e582993450..9698c8b04c 100644
--- a/etc/teams.scm.in
+++ b/etc/teams.scm.in
@@ -436,6 +436,21 @@  (define-team reproduciblebuilds
         "Reproducible Builds tooling and issues that affect any guix packages."
         #:scope (list "gnu/packages/diffoscope.scm")))
 
+(define-team gnome
+  (team 'gnome
+        #:name "Gnome team"
+        #:description
+        "The Gnome desktop environment, along with core technologies such as
+GLib/GIO, GTK, GStreamer and Webkit."
+        #:scope (list "gnu/packages/glib.scm"
+                      "gnu/packages/gstreamer.scm"
+                      "gnu/packages/gtk.scm"
+                      "gnu/packages/gnome.scm"
+                      "gnu/packages/gnome-xyz.scm"
+                      "gnu/packages/webkit.scm"
+                      "guix/build/glib-or-gtk-build-system.scm"
+                      "guix/build/meson-build-system.scm")))
+
 (define-team xfce
   (team 'xfce
         #:name "Xfce team"
@@ -511,7 +526,7 @@  (define-member (person "Florian Pelz"
 
 (define-member (person "Liliana Marie Prikler"
                        "liliana.prikler@gmail.com")
-  emacs games)
+  emacs games gnome)
 
 (define-member (person "Ricardo Wurmus"
                        "rekado@elephly.net")