diff mbox series

[bug#62251,v2] gnu: Add physlock.

Message ID 20230318142844.6457-1-sarg@sarg.org.ru
State New
Headers show
Series [bug#62251,v2] gnu: Add physlock. | expand

Commit Message

Sergey Trofimov March 18, 2023, 2:28 p.m. UTC
* gnu/packages/xdisorg.scm (physlock): New variable.
---
 gnu/packages/xdisorg.scm | 43 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)

Comments

Liliana Marie Prikler March 26, 2023, 6:05 a.m. UTC | #1
Am Samstag, dem 18.03.2023 um 15:28 +0100 schrieb Sergey Trofimov:
> * gnu/packages/xdisorg.scm (physlock): New variable.
Pushed.

Thanks
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 308fa131d6..d87857d4ff 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -2314,6 +2314,49 @@  (define-public xss-lock
       (home-page "https://bitbucket.org/raymonad/xss-lock")
       (license license:expat))))
 
+(define-public physlock
+  (package
+    (name "physlock")
+    (version "13")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/xyb3rt/physlock")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1mz4xxjip5ldiw9jgfq9zvqb6w10bcjfx6939w1appqg8f521a7s"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:tests? #f ;no tests
+           #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure)
+
+               (add-after 'unpack 'fix-makefile
+                 (lambda _
+                   (substitute* "main.c" ; remove extra newline in the prompt
+                     (("(fprintf.vt.ios, .%s.)\\n(., options->prompt)" all start end)
+                      (string-append start end)))
+                   (substitute* "Makefile" (("-m 4755 -o root -g root") "")))))
+
+           #:make-flags
+           #~(list "HAVE_SYSTEMD=0" "HAVE_ELOGIND=1"
+                   (string-append "CC=" #$(cc-for-target))
+                   (string-append "PREFIX=" #$output))))
+    (native-inputs (list linux-pam elogind))
+    (synopsis
+     "Screen lock utility that locks all virtual terminals at once.")
+    (description
+     "physlock only allows the user of the active session (the user logged into the
+foreground virtual terminal) to unlock the computer, and uses PAM for authentication.
+It is an alternative to @command{vlock -an}, written to overcome vlock's limitations
+regarding hibernate and suspend.  physlock has a very minimal interface, which is just
+a password prompt displayed in a tty console.")
+    (home-page "https://github.com/xyb3rt/physlock")
+    (license license:gpl2+)))
+
 (define-public python-pyperclip
   (package
     (name "python-pyperclip")