diff mbox series

[bug#60838,v2,4/7] gnu: Add python-pluggy-next.

Message ID 51068734c3ad24fcfeb8062995487aa47e54ec86.1679080713.git.felgru@posteo.net
State New
Headers show
Series Add datasette and python-sqlite-utils. | expand

Commit Message

Felix Gruber March 17, 2023, 7:19 p.m. UTC
* gnu/packages/python-xyz.scm (python-pluggy-next): New variable.
---
 gnu/packages/python-xyz.scm | 13 +++++++++++++
 1 file changed, 13 insertions(+)

Comments

Maxim Cournoyer March 22, 2023, 1:13 a.m. UTC | #1
Hi,

Felix Gruber <felgru@posteo.net> writes:

> * gnu/packages/python-xyz.scm (python-pluggy-next): New variable.
> ---
>  gnu/packages/python-xyz.scm | 13 +++++++++++++
>  1 file changed, 13 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index a6bd592837..af1799591e 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -15408,6 +15408,19 @@ (define-public python-pluggy
>     (home-page "https://pypi.org/project/pluggy/")
>     (license license:expat)))
>  
> +;;; TODO: Make this the default python-pluggy in the next rebuild cycle.
> +(define-public python-pluggy-next
> +  (package
> +   (inherit python-pluggy)
> +   (version "1.0.0")
> +   (source
> +    (origin
> +     (method url-fetch)
> +     (uri (pypi-uri "pluggy" version))
> +     (sha256
> +      (base32
> +       "0n8iadlas2z1b4h0fc73b043c7iwfvx9rgvqm1azjmffmhxkf922"))))))
> +
>  (define-public python-plumbum
>    (package
>      (name "python-plumbum")

I'll install this one to master in a moment.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a6bd592837..af1799591e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15408,6 +15408,19 @@  (define-public python-pluggy
    (home-page "https://pypi.org/project/pluggy/")
    (license license:expat)))
 
+;;; TODO: Make this the default python-pluggy in the next rebuild cycle.
+(define-public python-pluggy-next
+  (package
+   (inherit python-pluggy)
+   (version "1.0.0")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (pypi-uri "pluggy" version))
+     (sha256
+      (base32
+       "0n8iadlas2z1b4h0fc73b043c7iwfvx9rgvqm1azjmffmhxkf922"))))))
+
 (define-public python-plumbum
   (package
     (name "python-plumbum")