diff mbox series

[bug#53570,v2] gnu: Add texlive-ddphonism.

Message ID 20230318130215.271502-1-mail@nicolasgoaziou.fr
State New
Headers show
Series [bug#53570,v2] gnu: Add texlive-ddphonism. | expand

Commit Message

Nicolas Goaziou March 18, 2023, 1:02 p.m. UTC
From: jgart <jgart@dismail.de>

* gnu/packages/tex.scm (texlive-ddphonism): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
---
 gnu/packages/tex.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: 3893758dac76fc30b23d4715e849e262306f268d

Comments

jgart March 18, 2023, 4:07 p.m. UTC | #1
Hi,

LGTM, builds fine.

March 18, 2023 8:02 AM, "Nicolas Goaziou" <mail@nicolasgoaziou.fr> wrote:

> From: jgart <jgart@dismail.de>
> 
> * gnu/packages/tex.scm (texlive-ddphonism): New variable.
> 
> Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
> ---
> gnu/packages/tex.scm | 25 +++++++++++++++++++++++++
> 1 file changed, 25 insertions(+)
> 
> diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
> index 0c4e545edf..4f412614a1 100644
> --- a/gnu/packages/tex.scm
> +++ b/gnu/packages/tex.scm
> @@ -5393,6 +5393,31 @@ (define-public texlive-catchfile
> "Catchfile catches the contents of a file and puts it in a macro.")
> (license license:lppl1.3+))))
> 
> +(define-public texlive-ddphonism
> + (package
> + (inherit (simple-texlive-package
> + "texlive-ddphonism"
> + (list "doc/latex/ddphonism/"
> + "tex/latex/ddphonism/")
> + (base32 "1p02ai76nnh6042pnmqv4n30z6yxsvyyk2nb9jk7xlyyc87zzbdd")
> + #:trivial? #t))
> + (propagated-inputs
> + (list texlive-etoolbox
> + texlive-hyperref
> + texlive-latex-l3packages
> + texlive-listings
> + texlive-pgf
> + texlive-latex-tools
> + texlive-xstring))
> + (home-page "https://www.ctan.org/pkg/ddphonism")
> + (synopsis "Dodecaphonic diagrams for LaTeX")
> + (description
> + "This is a music-related package which is focused on notation from the
> +twelve-tone system, also called dodecaphonism. It provides LaTeX algorithms
> +that produce typical dodecaphonic notation based off a musical series, or row
> +sequence, of variable length.")
> + (license license:lppl1.3c)))
> +
> (define-public texlive-doi
> (package
> (inherit (simple-texlive-package
> 
> base-commit: 3893758dac76fc30b23d4715e849e262306f268d
> -- 
> 2.39.2
Nicolas Goaziou March 24, 2023, 9:15 a.m. UTC | #2
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

> LGTM, builds fine.

Applied. Thank you for the feedback.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0c4e545edf..4f412614a1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5393,6 +5393,31 @@  (define-public texlive-catchfile
        "Catchfile catches the contents of a file and puts it in a macro.")
       (license license:lppl1.3+))))
 
+(define-public texlive-ddphonism
+  (package
+    (inherit (simple-texlive-package
+              "texlive-ddphonism"
+              (list "doc/latex/ddphonism/"
+                    "tex/latex/ddphonism/")
+              (base32 "1p02ai76nnh6042pnmqv4n30z6yxsvyyk2nb9jk7xlyyc87zzbdd")
+              #:trivial? #t))
+    (propagated-inputs
+     (list texlive-etoolbox
+           texlive-hyperref
+           texlive-latex-l3packages
+           texlive-listings
+           texlive-pgf
+           texlive-latex-tools
+           texlive-xstring))
+    (home-page "https://www.ctan.org/pkg/ddphonism")
+    (synopsis "Dodecaphonic diagrams for LaTeX")
+    (description
+     "This is a music-related package which is focused on notation from the
+twelve-tone system, also called dodecaphonism.  It provides LaTeX algorithms
+that produce typical dodecaphonic notation based off a musical series, or row
+sequence, of variable length.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-doi
   (package
     (inherit (simple-texlive-package